Question

Untrusted connection

I think I made a mistake when installing the one click Ghost app and just put in www.domain.com when the terminal was prompting my domain. And now when I type in just domain.com browsers claim my site is not a trusted connection or it directs to the set up page.

But when I do https://www.domain.com it works just fine.

Is there a work around this? Or a way to edit?

Thanks


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hi there,

It sounds like that the SSL certificate was issued only for the www version of your domain name.

What I could suggest following the process for setting up SSL for a secondary domain with Ghost CLI as described in their official documentation here:

https://ghost.org/docs/ghost-cli/?_ga=2.130622223.1089047799.1639817071-1303272080.1639817071#knowledgebase

That way you could cover both the www and the non-www versions of your domain.

Best, Bobby