Ghost Update Error | Your node version is 16.13.0, but Ghost v5.82.4 require requires ^18.12.1

I have been stuck at the older Ghost version for a while now. I went the rabbit hole of updating the Node via Terminal, wasted hours with no success. Is there any practica way to upgrade my Ghost?

Thank you

Message: Ghost v5.82.4 is not compatible with the current Node version. Your node version is 16.13.0, but Ghost v5.82.4 requires ^18.12.1 || ^20.11.1


+ sudo systemctl is-active ghost_oykun-com

✔ Checking system Node.js version - found v16.13.0

✔ Ensuring user is not logged in as ghost user

✔ Checking if logged in user is directory owner

✔ Checking current folder permissions

✔ Checking folder permissions

✔ Checking file permissions

✔ Checking content folder ownership

✔ Checking memory availability

✔ Checking free space

✔ Checking for available migrations

✔ Checking for latest Ghost version

# 5.82.4

This release contains fixes for minor bugs and issues reported by Ghost users.


View the changelog for full details:

✔ Fetched release notes

✖ Downloading and updating Ghost to v5.82.4

A SystemError occurred.

Message: Ghost v5.82.4 is not compatible with the current Node version. Your node version is 16.13.0, but Ghost v5.82.4 requires ^18.12.1 || ^20.11.1

Debug Information:

    OS: Ubuntu, v20.04.3 LTS

    Node Version: v16.13.0

    Ghost Version: 5.46.0

    Ghost-CLI Version: 1.26.0

    Environment: production

    Command: 'ghost update'

Try running ghost doctor to check your system for known issues.

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Site Moderator
Site Moderator badge
April 28, 2024

Heya @designo,

You’ll need to update your NodeJS version first and then try the ghost upgrade command.

Update Node.js

Since Ghost v5.82.4 requires Node.js version ^18.12.1 or ^20.11.1, you’ll need to upgrade your Node.js installation. You can use Node Version Manager (nvm) to manage multiple Node.js versions easily. Here’s how to do it:

  1. Install or Update nvm: If you don’t have nvm installed, you can install it using the following command:
curl -o- | bash
Restart your terminal or run `source ~/.bashrc` (or your shell's equivalent) to use `nvm`.
  1. Install the Required Node.js Version:
nvm install 18.12.1  # You can also use 20.11.1 or the latest in 18.x or 20.x series nvm use 18.12.1
  1. Set Default Node Version for New Shells:
nvm alias default 18.12.1

Try DigitalOcean for free

Click below to sign up and get $200 of credit to try our products over 60 days!

Sign up

Featured on Community

Get our biweekly newsletter

Sign up for Infrastructure as a Newsletter.

Hollie's Hub for Good

Working on improving health and education, reducing inequality, and spurring economic growth? We'd like to help.

Become a contributor

Get paid to write technical tutorials and select a tech-focused charity to receive a matching donation.

Welcome to the developer cloud

DigitalOcean makes it simple to launch in the cloud and scale up as you grow — whether you're running one virtual machine or ten thousand.

Learn more
DigitalOcean Cloud Control Panel