Question

Unturned Host Ubuntu Droplet Lost Connection

I am attempting to install an unturned rocket server on an Ubuntu 14.04.4 Digital Ocean droplet. I get so far as to get the server on the master list, but when I attempt to connect I get no response for 30 seconds and then “this server lost your connection”. I have not installed a firewall yet I follow the README very carefully I have tried this on many droplets to make sure I am not missing a step

Here is the unturned.log that is created upon startup: http://pastebin.com/PB2L5f9u

I have tried deleting the mainData I have tried replacing the mainData with a friend’s

I attempted this last night (before the unturned update) and got the same result

Thank you :]

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

This question was answered by @BrookDO:

It’s possible you have script duplicates in your project. Take a look at your files to see if you have anything duplicated, and that may help.

View the original comment