uWSGI can't receive any request from Nginx

I raised a question on stackoverflow:

run wsgi with

uwsgi --ini /home/laike9m/Envs/blog/My_Blog/uwsgi.ini

Then I visit the public IP address via browser, Nginx gived me 502 error and there’s no request sent to uwsgi.

I’ve tried setting uid/git to www-data, but it didn’t work.

Thank you!

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

OK I solved it. See SO page.