Verifying domain ownership for Google Search Console

As I was following the directions on how to verify ownership through Google Search Console (, I got an error that said: “Sorry! Something went wrong.” I tried to create a new TXT record by posting the string from Google into the value field, selected “@” for the hostname, and selected 3600 as the TTL. Is there anything else I should be doing?

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

@blakeblaze15 I just tried it with a domain I own and had not previously verified, and it took a few seconds but it worked.


  1. Ensure the domain registrar is configured to point domain to DigitalOcean nameservers How To Point to DigitalOcean Nameservers From Common Domain Registrars
  2. Ensure you’ve added the top-level domain in DigitalOcean DNS ( no WWW or https)
  3. Type the top-level domain into the “Add” step in Search console
  4. Copy the TXT record from Google and paste it into TXT record section of your page on Control Panel, use @ for the Hostname
  5. Go back to Google, wait a few seconds, click Verify.


Here’s a screen recording of my process

Adding a TXT record to confirm google search console ownership on DigitalOcean

You can see it fails the first time I try to verify, but then I wait a few seconds and try again and it works

I had the exact same issue, followed the steps and ended up with the opaque “Something went wrong” error. For what it’s worth logging out and logging back in fixed it. Might be some authentication issue on your side.

Just wanted to follow up here. To the best of my knowledge I didn’t do anything differently, but when I tried today instead of the red pop-up “Sorry! Something went wrong” I got a successful green pop-up instead.