Question

Wordpress site showing IP address in address bar, not domain

My wordpress install is showing my IP address in the browser address bar instead of my domain name. My domain name ( paulapplegate.com ) is hosted at Google and an A record points to my droplet’s IP address (45.55.133.104) but in the address bar the URL looks like this http://45.55.133.104/wp-login.php?loggedout=true, instead of http://paulapplegate.com/wp-login.php?loggedout=true as you would expect.

What do I need to change to get what I expect, http://paulapplegate.com/wp-login.php ? Do I need to change /etc/hosts ? As an FYI I can’t access my WP install Settings-> General Page. I get the following error. “Safari can’t open the page"45.55.133.104/wp-admin/options-general.php” because the server unexpectedly dropped the connection. " I will try to replace the file with one from the install.

I am lost and know just enough to be dangerous to myself. Thanks for any help you can provide. Paul

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

I found a solution. https://www.digitalocean.com/community/questions/segmentation-fault-on-certain-wordpress-pages-on-ubuntu-apache-php?answer=20660

I can now access the Settings-> General page and change my WP name to the Domain name.

A little late but found a simple fix to this…

After getting all your cname/aliases set up, you would go to General settings->change “Site Address (URL)” to whatever your domain is. By default, it will list your site’s IP address.

libssh2-php was replaced with php-ssh2. Ran the following code then changed site address URL in wordpress to my domain and it started to work.

sudo apt-get dist-upgrade php-ssh2