Wrodpress Could not remove the old plugin Issues

  • Posted April 23, 2014

Hi, I am facing following issue, when i was trying to update this particular plugin on my centos droplet…

The update process is starting. This process may take a while on some hosts, so please be patient.

Updating Plugin WordPress SEO (1/1)

Downloading update from… Unpacking the update… Installing the latest version… Removing the old version of the plugin… Plugin update failed.

An error occurred while updating WordPress SEO: Could not remove the old plugin.

and also there is a error when try to delete that kind of particular plugin then it says…

Plugin could not be deleted due to an error: Could not fully remove the plugin(s) wordpress-seo/wp-seo.php.

Please help me to get out this kind of issues.



I am using Ubuntu 16.04, and I have my blog at /var/www/html/blog. I have also run into this issue. Previously, I had it under www-data:www-data ownership, with directory=0755 and file=0644, but I was not able to update or create new directories via the web interface. So I had to go back to 7777, and then I tried doing an update on a few plug-ins, like page builder, but it said failed to remove the old plugin. The update has completed successfully. I’m not sure what could be causing this problem.

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

You need to make sure that the folder permissions/ownership are correct. <br> <br><pre> <br>chown -R apache:apache /var/www/wordpress/ <br></pre> <br> <br>Replace “/var/www/wordpress/” with the path to where you actually have wordpress. If you are using nginx instead of apache, use the nginx user as the owner.


Suggestion from Wordpress Cub worked for me…

Can you try remove it manually?