Question

www.domain.com not working, domain.com working, why??

Hi,

I created a virtual host and httpd.conf reads as follows

<VirtualHost 146.185.136.14> DocumentRoot /srv/http/shilpi.com ServerName shilpi.com ServerAlias www.shilpi.com ErrorLog “/var/log/httpd/shilpi.com-error_log” CustomLog “/var/log/httpd/shilpi.com-access_log” common <Directory “/srv/http/shilpi.com”> Options Indexes FollowSymLinks MultiViews AllowOverride All Order allow,deny allow from all </Directory> </VirtualHost>

Now when I visit http://shilpi.com it works but if I visit www.shilpi.com I get the message webpage is not available.

Anybody any clue???

Thanks


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Its working now. <br> <br>I put www in the left column and @ in the right column in CNAME record. <br> <br>Thanks

My domain is not working with http but it is working with www. How to overcome this?

thinking about it, I think @ on the right will only work with a CNAME. <br> <br>if you add an A, put in your IP address on the right, <br>if you add a CNAME, put in shilpi.com on the right <br> <br>CNAME or A will work, you only need one or the other, not both.