Tutorial

How to Install and Configure VNC on Ubuntu 22.04

How to Install and Configure VNC on Ubuntu 22.04
Not using Ubuntu 22.04?Choose a different version or distribution.
Ubuntu 22.04

Introduction

Virtual Network Computing, or VNC, is a connection system that allows you to use your keyboard and mouse to interact with a graphical desktop environment on a remote server. It makes managing files, software, and settings on a remote server easier for users who are not yet comfortable with the command line.

In this guide, you’ll set up a VNC server with TightVNC on an Ubuntu 22.04 server and connect to it securely through an SSH tunnel. Then, you’ll use a VNC client program on your local machine to interact with your server through a graphical desktop environment.

Prerequisites

To complete this tutorial, you’ll need:

  • One Ubuntu 22.04 server with a non-root administrative user and a firewall configured with UFW. To set this up, follow our initial server setup guide for Ubuntu 22.04.
  • A local computer with a VNC client installed. The VNC client you use must support connections over SSH tunnels:

Step 1 — Installing the Desktop Environment and VNC Server

By default, an Ubuntu 22.04 server does not come with a graphical desktop environment or a VNC server installed, so you’ll begin by installing those.

You have many options when it comes to which VNC server and desktop environment you choose. In this tutorial, you will install packages for the latest Xfce desktop environment and the TightVNC package available from the official Ubuntu repository. Both Xfce and TightVNC are known for being lightweight and fast, which will help ensure that the VNC connection will be smooth and stable even on slower internet connections.

After connecting to your server with SSH, update your list of packages:

  1. sudo apt update

Now install Xfce along with the xfce4-goodies package, which contains a few enhancements for the desktop environment:

  1. sudo apt install xfce4 xfce4-goodies

During installation, you may be prompted to choose a default display manager for Xfce. A display manager is a program that allows you to select and log in to a desktop environment through a graphical interface. You’ll only be using Xfce when you connect with a VNC client, and in these Xfce sessions you’ll already be logged in as your non-root Ubuntu user. So for the purposes of this tutorial, your choice of display manager isn’t pertinent. Select either one and press ENTER.

Once that installation completes, install the TightVNC server:

  1. sudo apt install tightvncserver

Next, run the vncserver command to set a VNC access password, create the initial configuration files, and start a VNC server instance:

  1. vncserver

You’ll be prompted to enter and verify a password to access your machine remotely:

Output
You will require a password to access your desktops. Password: Verify:

The password must be between six and eight characters long. Passwords more than 8 characters will be truncated automatically.

Once you verify the password, you’ll have the option to create a view-only password. Users who log in with the view-only password will not be able to control the VNC instance with their mouse or keyboard. This is a helpful option if you want to demonstrate something to other people using your VNC server, but this isn’t required.

The process then creates the necessary default configuration files and connection information for the server. Additionally, it launches a default server instance on port 5901. This port is called a display port, and is referred to by VNC as :1. VNC can launch multiple instances on other display ports, with :2 referring to port 5902, :3 referring to 5903, and so on:

Output
Would you like to enter a view-only password (y/n)? n xauth: file /home/sammy/.Xauthority does not exist New 'X' desktop is your_hostname:1 Creating default startup script /home/sammy/.vnc/xstartup Starting applications specified in /home/sammy/.vnc/xstartup Log file is /home/sammy/.vnc/your_hostname:1.log

Note that if you ever want to change your password or add a view-only password, you can do so with the vncpasswd command:

  1. vncpasswd

At this point, the VNC server is installed and running. Now you’ll configure it to launch Xfce and give us access to the server through a graphical interface.

Step 2 — Configuring the VNC Server

The VNC server needs to know which commands to run when it starts up. Specifically, VNC needs to know which graphical desktop environment it should connect to.

The commands that the VNC server runs at startup are located in a configuration file called xstartup in the .vnc folder under your home directory. The startup script was created when you ran the vncserver command in the previous step, but you’ll create your own to launch the Xfce desktop.

Because you are going to be changing how the VNC server is configured, first stop the VNC server instance that is running on port 5901 with the following command:

  1. vncserver -kill :1

The output will look like this, although you’ll see a different PID:

Output
Killing Xtightvnc process ID 17648

Before you modify the xstartup file, back up the original:

  1. mv ~/.vnc/xstartup ~/.vnc/xstartup.bak

Now create a new xstartup file and open it in a text editor, such as nano:

  1. nano ~/.vnc/xstartup

Then add the following lines to the file:

~/.vnc/xstartup
#!/bin/bash
xrdb $HOME/.Xresources
startxfce4 &

The first line is a shebang. In executable plain-text files on *nix platforms, a shebang tells the system what interpreter to pass that file to for execution. In this case, you’re passing the file to the Bash interpreter. This will allow each successive line to be executed as commands, in order.

The first command in the file, xrdb $HOME/.Xresources, tells VNC’s GUI framework to read the server user’s .Xresources file. .Xresources is where a user can make changes to certain settings of the graphical desktop, like terminal colors, cursor themes, and font rendering. The second command tells the server to launch Xfce. Whenever you start or restart the VNC server, these commands will execute automatically.

Save and close the file after adding these lines. If you used nano, do so by pressing CTRL + X, Y, then ENTER.

To ensure that the VNC server will be able to use this new startup file properly, you’ll need to make it executable:

  1. chmod +x ~/.vnc/xstartup

Then restart the VNC server:

  1. vncserver -localhost

Notice that this time the command includes the -localhost option, which binds the VNC server to your server’s loopback interface. This will cause VNC to only allow connections that originate from the server on which it’s installed.

In the next step, you’ll establish an SSH tunnel between your local machine and your server, essentially tricking VNC into thinking that the connection from your local machine originated on your server. This strategy will add an extra layer of security around VNC, as the only users who will be able to access it are those that already have SSH access to your server.

You’ll see output similar to this:

Output
New 'X' desktop is your_hostname:1 Starting applications specified in /home/sammy/.vnc/xstartup Log file is /home/sammy/.vnc/your_hostname:1.log

With the configuration in place, you’re ready to connect to the VNC server from your local machine.

Step 3 — Connecting to the VNC Desktop Securely

VNC itself doesn’t use secure protocols when connecting. To securely connect to your server, you’ll establish an SSH tunnel and then tell your VNC client to connect using that tunnel rather than making a direct connection.

Create an SSH connection on your local computer that securely forwards to the localhost connection for VNC. You can do this via the terminal on Linux or macOS with the following ssh command:

  1. ssh -L 59000:localhost:5901 -C -N -l sammy your_server_ip

Here’s what this ssh command’s options mean:

  • -L 59000:localhost:5901: The -L switch specifies that the given port on the local computer (59000) is to be forwarded to the given host and port on the destination server (localhost:5901, meaning port 5901 on the destination server, defined as your_server_ip). Note that the local port you specify is somewhat arbitrary; as long as the port isn’t already bound to another service, you can use it as the forwarding port for your tunnel.
  • -C: This flag enables compression which can help minimize resource consumption and speed things up.
  • -N: This option tells ssh that you don’t want to execute any remote commands. This setting is useful when you just want to forward ports.
  • -l sammy your_server_ip: The -l switch lets you specify the user you want to log in as once you connect to the server. Make sure to replace sammy and your_server_ip with the name of your non-root user and your server’s IP address.

Note: This command establishes an SSH tunnel that forwards information from port 5901 on your VNC server to port 59000 on your local machine via port 22 on each machine, the default port for SSH. Assuming you followed the prerequisite Initial Server Setup guide for Ubuntu 22.04, you will have added a UFW rule to allow connections to your server over OpenSSH.

This is more secure than simply opening up your server’s firewall to allow connections to port 5901, as that would allow anyone to access your server over VNC. By connecting over an SSH tunnel, you’re limiting VNC access to machines that already have SSH access to the server.

If you are using PuTTY to connect to your server, you can create an SSH tunnel by right-clicking on the top bar of the terminal window, and then clicking the Change Settings… option:

Right-click on top bar to reveal Change Settings option

Find the Connection branch in the tree menu on the left-hand side of the PuTTY Reconfiguration window. Expand the SSH branch and click on Tunnels. On the Options controlling SSH port forwarding screen, enter 59000 as the Source Port and localhost:5901 as the Destination, like this:

Example PuTTY SSH tunnel configuration

Then click the Add button, and then the Apply button to implement the tunnel.

Once the tunnel is running, use a VNC client to connect to localhost:59000. You’ll be prompted to authenticate using the password you set in Step 1.

Once you are connected, you’ll see the default Xfce desktop. It should look something like this:

VNC connection to Ubuntu 22.04 server with the Xfce desktop environment

You can access files in your home directory with the file manager or from the command line, as seen here:

File Manager via VNC connection to Ubuntu 22.04

Press CTRL+C in your local terminal to stop the SSH tunnel and return to your prompt. This will disconnect your VNC session as well.

Now you can configure your VNC server to run as a systemd service.

Step 4 — Running VNC as a System Service

By setting up the VNC server to run as a systemd service you can start, stop, and restart it as needed, like any other service. You can also use systemd’s management commands to ensure that VNC starts when your server boots up.

First, create a new unit file called /etc/systemd/system/vncserver@.service:

  1. sudo nano /etc/systemd/system/vncserver@.service

The @ symbol at the end of the name will let us pass in an argument you can use in the service configuration. You’ll use this to specify the VNC display port you want to use when you manage the service.

Add the following lines to the file. Be sure to change the value of User, Group, WorkingDirectory, and the username in the value of PIDFILE to match your username:

/etc/systemd/system/vncserver@.service
[Unit]
Description=Start TightVNC server at startup
After=syslog.target network.target

[Service]
Type=forking
User=sammy
Group=sammy
WorkingDirectory=/home/sammy

PIDFile=/home/sammy/.vnc/%H:%i.pid
ExecStartPre=-/usr/bin/vncserver -kill :%i > /dev/null 2>&1
ExecStart=/usr/bin/vncserver -depth 24 -geometry 1280x800 -localhost :%i
ExecStop=/usr/bin/vncserver -kill :%i

[Install]
WantedBy=multi-user.target

The ExecStartPre command stops VNC if it’s already running. The ExecStart command starts VNC and sets the color depth to 24-bit color with a resolution of 1280x800. You can modify these startup options as well to meet your needs. Also, note that the ExecStart command again includes the -localhost option.

Save and close the file.

Next, make the system aware of the new unit file:

  1. sudo systemctl daemon-reload

Enable the unit file:

  1. sudo systemctl enable vncserver@1.service

The 1 following the @ sign signifies which display number the service should appear over, in this case the default :1 as was discussed in Step 2.

Stop the current instance of the VNC server if it’s still running:

  1. vncserver -kill :1

Then start it as you would start any other systemd service:

  1. sudo systemctl start vncserver@1

You can verify that it started with this command:

  1. sudo systemctl status vncserver@1

If it started correctly, the output should look like this:

Output
● vncserver@1.service - Start TightVNC server at startup Loaded: loaded (/etc/systemd/system/vncserver@.service; enabled; vendor preset: enabled) Active: active (running) since Mon 2022-04-18 16:57:26 UTC; 20s ago Process: 97088 ExecStartPre=/usr/bin/vncserver -kill :1 > /dev/null 2>&1 (code=exited, status=2) Process: 97092 ExecStart=/usr/bin/vncserver -depth 24 -geometry 1280x800 -localhost :1 (code=exited, status=0/SUCCESS) Main PID: 97103 (Xtightvnc) Tasks: 77 (limit: 4665) Memory: 146.7M CPU: 4.459s CGroup: /system.slice/system-vncserver.slice/vncserver@1.service . . .

Your VNC server is now ready to use whenever your server boots up, and you can manage it with systemctl commands like any other systemd service.

However, there won’t be any difference on the client side. To reconnect, start your SSH tunnel again:

  1. ssh -L 59000:localhost:5901 -C -N -l sammy your_server_ip

Then make a new connection using your VNC client software to localhost:59000 to connect to your server.

Conclusion

You now have a secured VNC server up and running on your Ubuntu 22.04 server. Now you’ll be able to manage your files, software, and settings with a user-friendly graphical interface, and you’ll be able to run graphical software like web browsers remotely.

Thanks for learning with the DigitalOcean Community. Check out our offerings for compute, storage, networking, and managed databases.

Learn more about our products


About the authors
Default avatar

Manager, Developer Education

Technical Writer @ DigitalOcean



Still looking for an answer?

Ask a questionSearch for more help

Was this helpful?
 
9 Comments


This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

It does not work for me. I tried also with the gnome desktop. I always get the gray screen. I tried every solution from the first 5 pages of google and forums, still nothing. I only managed to change the x cursor to a normal curson, and manage to get a really sketchy lxde desktop interface. Does it have something to do with Xorg? Can you please help me?

When I followed the instructions above for creating the service, starting the service failed with the error message

Can't find file ~/.vnc/interactive-UN45:1.pid

In the systemd-documentation, I found an example of a traditional forking service. It says the following on PID-files:

Note that the daemon should write that file before finishing with its initialization. Otherwise, systemd might try to read the file before it exists.

I added the creation of a PID file to the service startup, and that appears to work:

ExecStartPre=/usr/bin/touch /home/interactive/.vnc/%H:%i.pid

However, the systemd-documentation includes the following under PIDFile:

Note that PID files should be avoided in modern projects. Use Type=notify,Type=notify-reload or Type=simple where possible, which does not require use of PID files to determine the main process of a service and avoids needless forking.

Would it be possible to avoid forking and PID-files for the vnc-service?

This comment has been deleted

    Hi I followed this guide and as usual everything worked great. thank you for . sharing your knowledge.

    But can i ask a couple questions please, when i tunnel in via ssh and then connect with vnc i still get the connection is unencrypted on vnc error. is this normal? is there no way to have a secure connection?

    and also to add that i use eset security which has banking security on my pc browser, but when i tunnel into server it says that my pc is unsecure and that its being controlled remotely and that its unsafe to do banking etc. why would this be.

    appreciate the help please. thanks

    (Ubuntu server 22.04) I followed Step 4, ‘Running VNC as a System Service’, but encountered an issue when trying to start the VNC function. While using the command ‘ps -x’, I could see that the TightVNC service was already running. However, when attempting to VNC, I received an error message stating ‘target machine actively refused it’. To resolve this, I had to manually terminate the TightVNC service using the command ‘vncserver -kill :1’, and then restart the service with the command ‘vncserver’. After doing this, I was able to successfully use the VNC function. Please help

    I followed each step and got it working on Ubuntu Server 22.04 running on a Raspberry Pi 4. I then used TightVNC Viewer (shows up as TigerVNC Viewer) on my Ubuntu Desktop 22.04-LTS to view the remote

    Followed everything step by step and got the vncserver to work on my Ubuntu Server 22.04 running on a Raspberry Pi 4

    I use TightVNC viewer (shows up as TigerVNC Viewer) on my Ubuntu desktop 22.04 to view the remote (server)

    Hi, thanks for writing all of this up. Clearly a large effort and very much appreciated.

    Sadly, it didn’t come even close to working for me. Pretty much a disaster from start to end.

    My logs (for what it’s worth as I am abandoning this now):


    07/03/23 20:56:10 Xvnc version TightVNC-1.3.10 07/03/23 20:56:10 Copyright © 2000-2009 TightVNC Group 07/03/23 20:56:10 Copyright © 1999 AT&T Laboratories Cambridge 07/03/23 20:56:10 All Rights Reserved. 07/03/23 20:56:10 See http://www.tightvnc.com/ for information on TightVNC 07/03/23 20:56:10 Desktop name ‘X’ (bob:1) 07/03/23 20:56:10 Protocol versions supported: 3.3, 3.7, 3.8, 3.7t, 3.8t 07/03/23 20:56:10 Listening for VNC connections on TCP port 5901 Font directory ‘/usr/share/fonts/X11/75dpi/’ not found - ignoring Font directory ‘/usr/share/fonts/X11/100dpi/’ not found - ignoring xrdb: No such file or directory xrdb: can’t open file ‘/home/nello/.Xresources’ /usr/bin/startxfce4: X server already running on display :1 gpg-agent: a gpg-agent is already running - not starting a new one

    (xfwm4:40107): xfwm4-WARNING **: 20:56:12.091: XSync extension too old (3.0).

    (xfwm4:40107): xfwm4-WARNING **: 20:56:12.091: The display does not support the XRender extension.

    (xfwm4:40107): xfwm4-WARNING **: 20:56:12.091: The display does not support the XRandr extension.

    (xfwm4:40107): xfwm4-WARNING **: 20:56:12.091: The display does not support the XRes extension.

    (xfwm4:40107): xfwm4-WARNING **: 20:56:12.092: The display does not support the XComposite extension.

    (xfwm4:40107): xfwm4-WARNING **: 20:56:12.092: The display does not support the XDamage extension.

    (xfwm4:40107): xfwm4-WARNING **: 20:56:12.092: The display does not support the XFixes extension.

    (xfwm4:40107): xfwm4-WARNING **: 20:56:12.092: The display does not support the XPresent extension.

    (xfwm4:40107): xfwm4-WARNING **: 20:56:12.092: Compositing manager disabled. xfwm4-Message: 20:56:12.109: Unsupported keyboard modifier ‘<Super>Tab’ xfwm4-Message: 20:56:12.109: Unsupported keyboard modifier ‘<Super>KP_Up’ xfwm4-Message: 20:56:12.109: Unsupported keyboard modifier ‘<Super>KP_Left’ xfwm4-Message: 20:56:12.109: Unsupported keyboard modifier ‘<Super>KP_Right’ xfwm4-Message: 20:56:12.109: Unsupported keyboard modifier ‘<Super>KP_Down’ xfwm4-Message: 20:56:12.109: Unsupported keyboard modifier ‘<Super>KP_End’ xfwm4-Message: 20:56:12.109: Unsupported keyboard modifier ‘<Super>KP_Next’ xfwm4-Message: 20:56:12.109: Unsupported keyboard modifier ‘<Super>KP_Home’ xfwm4-Message: 20:56:12.109: Unsupported keyboard modifier ‘<Super>KP_Page_Up’

    (xfwm4:40107): xfwm4-WARNING **: 20:56:12.112: Cannot find visual format on screen 0

    (xfwm4:40107): GLib-CRITICAL **: 20:56:12.112: g_hash_table_destroy: assertion ‘hash_table != NULL’ failed

    (xfsettingsd:40115): xfsettingsd-CRITICAL **: 20:56:12.130: No RANDR extension found in display :1. Display settings won’t be applied. Xlib: extension “XInputExtension” missing on display “:1”.

    (xfsettingsd:40115): xfsettingsd-CRITICAL **: 20:56:12.130: XI is not present.

    (xfsettingsd:40115): xfsettingsd-CRITICAL **: 20:56:12.130: Failed to initialize the Xkb extension.

    (xfsettingsd:40115): xfsettingsd-CRITICAL **: 20:56:12.130: Failed to initialize the Accessibility extension. xfwm4-Message: 20:56:12.174: Unsupported keyboard modifier ‘<Super>Tab’ xfwm4-Message: 20:56:12.174: Unsupported keyboard modifier ‘<Super>KP_Up’ xfwm4-Message: 20:56:12.174: Unsupported keyboard modifier ‘<Super>KP_Left’ xfwm4-Message: 20:56:12.174: Unsupported keyboard modifier ‘<Super>KP_Right’ xfwm4-Message: 20:56:12.174: Unsupported keyboard modifier ‘<Super>KP_Down’ xfwm4-Message: 20:56:12.174: Unsupported keyboard modifier ‘<Super>KP_End’ xfwm4-Message: 20:56:12.174: Unsupported keyboard modifier ‘<Super>KP_Next’ ** (xfce4-power-manager:40130): WARNING **: 20:56:12.410: Failed to get name owner: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Could not get owner of name ‘org.freedesktop.PowerManagement’: no such name

    ** (xfce4-power-manager:40130): WARNING **: 20:56:12.411: Failed to get name owner: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Could not get owner of name ‘org.xfce.PowerManager’: no such name

    AUDIT: Tue Mar 7 20:56:12 2023: 39987 Xtightvnc: client 10 rejected from local host Failure: Module initialisation failed

    ** (xiccd:40170): CRITICAL **: 20:56:12.435: RandR extension is not working on display :1.0 error: autostart failed:

    • “ubuntu-software-service.desktop”: skipped: current desktop [“XFCE”] not included in [“GNOME” “Unity”]

    Xlib: extension “DPMS” missing on display “:1.0”.

    (xfce4-power-manager:40130): xfce4-power-manager-WARNING **: 20:56:12.486: Monitor is not DPMS capable

    (xfce4-power-manager:40130): GLib-GObject-WARNING **: 20:56:12.547: …/…/…/gobject/gsignal.c:2613: signal ‘Changed’ is invalid for instance ‘0x5586cf987920’ of type ‘GDBusProxy’

    (xfce4-power-manager:40130): xfce4-power-manager-WARNING **: 20:56:12.575: could not map keysym 1008ff2a to keycode

    (xfce4-power-manager:40130): xfce4-power-manager-WARNING **: 20:56:12.575: could not map keysym 1008ffa8 to keycode

    (xfce4-power-manager:40130): xfce4-power-manager-WARNING **: 20:56:12.575: could not map keysym 1008ffa7 to keycode

    (xfce4-power-manager:40130): xfce4-power-manager-WARNING **: 20:56:12.575: could not map keysym 1008ff2f to keycode

    (xfce4-power-manager:40130): xfce4-power-manager-WARNING **: 20:56:12.575: could not map keysym 1008ff02 to keycode

    (xfce4-power-manager:40130): xfce4-power-manager-WARNING **: 20:56:12.575: could not map keysym 1008ff03 to keycode

    (xfce4-power-manager:40130): xfce4-power-manager-WARNING **: 20:56:12.575: could not map keysym 1008ff93 to keycode

    (xfce4-power-manager:40130): xfce4-power-manager-WARNING **: 20:56:12.575: could not map keysym 1008ff05 to keycode

    (xfce4-power-manager:40130): xfce4-power-manager-WARNING **: 20:56:12.575: could not map keysym 1008ff06 to keycode

    (xfce4-power-manager:40130): xfce4-power-manager-WARNING **: 20:56:12.575: No idle counter.

    (xfce4-power-manager:40130): xfce4-power-manager-WARNING **: 20:56:12.585: Unable to inhibit systemd sleep: GDBus.Error:org.freedesktop.DBus.Error.AccessDenied: Permission denied

    ** (xfce4-power-manager:40130): WARNING **: 20:56:12.585: No XRANDR extension found

    (xfce4-power-manager:40130): xfce4-power-manager-WARNING **: 20:56:12.590: Failed to get keyboard max brightness level : GDBus.Error:org.freedesktop.DBus.Error.UnknownMethod: Object does not exist at path “/org/freedesktop/UPower/KbdBacklight”

    (xfce4-power-manager:40130): xfce4-power-manager-WARNING **: 20:56:12.590: Failed to get keyboard max brightness level : GDBus.Error:org.freedesktop.DBus.Error.UnknownMethod: Object does not exist at path “/org/freedesktop/UPower/KbdBacklight”

    ** (xfdesktop:40127): WARNING **: 20:56:12.595: Failed to set the background ‘/usr/share/backgrounds/xfce/xfce-verticals.png’: GDBus.Error:org.freedesktop.DBus.Error.InvalidArgs: No such interface “org.freedesktop.DisplayManager.AccountsService” Process already running (98:Address already in use). Exiting.

    (tracker-miner-fs-3:40131): Tracker-CRITICAL **: 20:56:12.763: Could not request DBus name ‘org.freedesktop.Tracker3.Miner.Files’: D-Bus service name:‘org.freedesktop.Tracker3.Miner.Files’ is already taken, perhaps the application is already running?

    ** (wrapper-2.0:40283): WARNING **: 20:56:13.122: Binding ‘XF86AudioLowerVolume’ failed!

    (wrapper-2.0:40283): pulseaudio-plugin-WARNING **: 20:56:13.122: Could not have grabbed volume control keys. Is another volume control application (xfce4-volumed) running?

    ** (wrapper-2.0:40283): WARNING **: 20:56:13.122: Binding ‘XF86AudioPlay’ failed!

    (wrapper-2.0:40283): pulseaudio-plugin-WARNING **: 20:56:13.122: Could not have grabbed multimedia control keys.

    ** (wrapper-2.0:40285): WARNING **: 20:56:13.127: No XRANDR extension found

    (wrapper-2.0:40286): GLib-GIO-CRITICAL **: 20:56:13.129: g_file_new_for_path: assertion ‘path != NULL’ failed

    (wrapper-2.0:40286): GLib-GIO-CRITICAL **: 20:56:13.129: g_file_monitor_file: assertion ‘G_IS_FILE (file)’ failed

    (wrapper-2.0:40286): GLib-GObject-WARNING **: 20:56:13.129: invalid (NULL) pointer instance

    (wrapper-2.0:40286): GLib-GObject-CRITICAL **: 20:56:13.129: g_signal_connect_data: assertion ‘G_TYPE_CHECK_INSTANCE (instance)’ failed

    (wrapper-2.0:40286): Gtk-WARNING **: 20:56:13.129: Attempting to add a widget with type GtkToggleButton to a container of type XfcePanelPlugin, but the widget is already inside a container of type XfcePanelPlugin, please remove the widget from its existing container first.

    (wrapper-2.0:40285): Gtk-CRITICAL **: 20:56:13.152: gtk_icon_theme_has_icon: assertion ‘icon_name != NULL’ failed

    (wrapper-2.0:40285): Gtk-CRITICAL **: 20:56:13.153: gtk_icon_theme_has_icon: assertion ‘icon_name != NULL’ failed

    (wrapper-2.0:40285): Gtk-CRITICAL **: 20:56:13.153: gtk_icon_theme_has_icon: assertion ‘icon_name != NULL’ failed

    (wrapper-2.0:40301): Gtk-WARNING **: 20:56:13.189: Negative content width -1 (allocation 1, extents 1x1) while allocating gadget (node button, owner XfceArrowButton)

    (wrapper-2.0:40283): Gtk-WARNING **: 20:56:13.193: Negative content width -3 (allocation 1, extents 2x2) while allocating gadget (node button, owner PulseaudioButton)

    (wrapper-2.0:40286): Gtk-WARNING **: 20:56:13.195: Negative content width -3 (allocation 1, extents 2x2) while allocating gadget (node button, owner GtkToggleButton)

    (wrapper-2.0:40285): Gtk-CRITICAL **: 20:56:13.200: gtk_icon_theme_has_icon: assertion ‘icon_name != NULL’ failed

    (wrapper-2.0:40285): Gtk-WARNING **: 20:56:13.213: Negative content width -3 (allocation 1, extents 2x2) while allocating gadget (node button, owner PowerManagerButton)

    (update-notifier:40144): libayatana-appindicator-WARNING **: 20:56:15.185: Unable to connect to the Notification Watcher: GDBus.Error:org.freedesktop.DBus.Error.NoReply: Message recipient disconnected from message bus without replying xfce4-panel-Message: 20:56:15.186: Plugin systray-6 has been automatically restarted after crash.

    (update-notifier:40144): libayatana-appindicator-WARNING **: 20:56:15.186: Unable to connect to the Notification Watcher: GDBus.Error:org.freedesktop.DBus.Error.NoReply: Message recipient disconnected from message bus without replying Xlib: extension “DPMS” missing on display “:1.0”. Xlib: extension “DPMS” missing on display “:1.0”. Xlib: extension “DPMS” missing on display “:1.0”.


    Basically, I think there’s a whole lot of stuff this tutorial has assumed that just isn’t there.

    Sadly, this is very characteristic of my Ubuntu experience. I guess it’s just never the year of Linux on the destop, is it.

    If you get " xiccd has closed unexpectedly "

    run " sudo apt purge gnome-screensaver xfce4-screensaver "

    Try DigitalOcean for free

    Click below to sign up and get $200 of credit to try our products over 60 days!

    Sign up

    Join the Tech Talk
    Success! Thank you! Please check your email for further details.

    Please complete your information!

    Featured on Community

    Get our biweekly newsletter

    Sign up for Infrastructure as a Newsletter.

    Hollie's Hub for Good

    Working on improving health and education, reducing inequality, and spurring economic growth? We'd like to help.

    Become a contributor

    Get paid to write technical tutorials and select a tech-focused charity to receive a matching donation.

    Welcome to the developer cloud

    DigitalOcean makes it simple to launch in the cloud and scale up as you grow — whether you're running one virtual machine or ten thousand.

    Learn more
    DigitalOcean Cloud Control Panel