i created a Symfony Project from Github. Now i need as default path the /publlic folder. I try it with the HTTP Routes (i add there /public) but this is not working and not the solution.

My folder looks like this:
Ubuntu: ls
readme.md .env assets bin public

My Domain look like this:

This is working:

But i need the Public folder in the Root Domain. How i can configure it?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Submit an Answer
3 answers

To specify the root directory for your project you can use the “source_dir” parameter in the App Spec yaml. Apps can be created with App Spec yaml via the API or doctl.

try with the yaml config and add:

run_command: heroku-php-apache2 public/