Trying to upgrade to the new do agent, but I’m getting the following error:


Installing apt repository…
Installing gpg key…OK
WARNING: The following packages cannot be authenticated!
do-agent
E: There are problems and -y was used without –force-yes

Ubuntu 14.04 - is this the problem? Can anyone help? Thanks.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
3 answers

Hello, @unarmedwombat

I can see that this has been reported as an issue several times in other forums too. Can you please check if SELinux is enabled?

Let me know how it goes.

Same here. SELinux not enabled.

Hello @unarmedwombat & @bdokimakis, Is there a package I should install that is not automatically installed to be able to upgrade the do-agent/monitoring application? The same happened to me as above, authentication issues:

The program ‘sestatus’ is currently not installed.

I got Ubuntu 14.04 and get a message saying that I can install the “policycoreutils”. Should the mear installation solve the issue? Or do I need a config later? Or is a upgrade to 16.04 going to solve this?

Submit an Answer