Can't Install MySQL on Dokku

I’ve set up the droplet and when I run dokku mysql:create www I get:

mkdir: cannot create directory ‘/home/git’: Permission denied

I can’t figure out how to get past this.

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

I’m also getting the Unknown command: ‘null’ error even after upgrading docker and cloning the forked mysql plugin. I also tried the mariadb plugin, but that didn’t work too well either. So far it seems like everything is changing too fast for all the plugins to keep up :(

Try running the commands as root. You can run <code>sudo -s</code> as a user with sudo privileges to log in as root.

Running into the same issue. I followed your directions above but I’m still getting a permission denied message.