Confused Why My App Deploy/Build Failed

My build seems to have worked, it installed my app and it says build complete.

Under Activity > Deployment > Logs > Build Logs there is a check next to service, and the logs say ✔ build complete in green.

Under Activity > Deployment > Logs > Deploy Logs there’s a red [!], and after I ran it it said it failed to deploy. But in these logs, I see the normal logs from my app starting up and even starting to work, but then it ends with no error or anything.

Why did it say it failed if my app seemed to be working normally and shows no error?

I did find it strange that it said the build was in progress after my app had already started, so maybe I configured something wrong, like it expects a build script that ends once it’s ready or something?

This is for a discord bot using node.js that will run continuously.

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Accepted Answer

I have solved this.

The problem is it was configured to be a web server, and they were performing an automatic health check after 90 seconds to see if my server responded, which it did not because it is not a server, so it killed the app.

I was not aware there are different types of apps, and one can be a worker without a web server, which is what I need. After switching to this resource type, it is now running just fine.

Hi I am experiencing the same issue on a swift Vapor project that was running fine until now.

  • Deploy runs
  • [2024-03-21 17:55:45] [ NOTICE ] Server starting on (Vapor/HTTPServer.swift:298) [] And then deploy fails and I get the rollback dance.

No idea what is happening :/ Is there a way to get some help @KFSys ?

Site Moderator
Site Moderator badge
January 21, 2024

Heya @skeddtemp,

That’s really weird.

By saing it’s starting to work, do you mean it works and as soon as you open your app it fails or it says it’s working for sometime and it fails without any interaction?

As soon as it fails do you see anything in the logs?

Try DigitalOcean for free

Click below to sign up and get $200 of credit to try our products over 60 days!

Sign up

Featured on Community

Get our biweekly newsletter

Sign up for Infrastructure as a Newsletter.

Hollie's Hub for Good

Working on improving health and education, reducing inequality, and spurring economic growth? We'd like to help.

Become a contributor

Get paid to write technical tutorials and select a tech-focused charity to receive a matching donation.

Welcome to the developer cloud

DigitalOcean makes it simple to launch in the cloud and scale up as you grow — whether you're running one virtual machine or ten thousand.

Learn more
DigitalOcean Cloud Control Panel