Connected with SSH as root but ask for password


Part of a team, I try to connect to a droplet.

  • I have added my SSH Key. I can connect as root but prompt ask me for password. My colleague (owner) does not have this issue.

We tried disable the Password for Root Login as explained here :

but still the same. Any ideas ?



Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Accepted Answer

Was your ssh key added to the droplet when it was created? If not, you will need to manually add your public key to /root/.ssh/authorized_keys before it can be used. Adding it to the control panel will make it available when you create a new droplet but will not add it to droplets that already exist.

This comment has been deleted