Console extremely slow to responde

I’m running OSX 10.11.6 and when I try to access the console for one of my droplets I get an extremely slow response time, it could be up to 1 minute from the point I type something until it appears in the console. I tried accessing the console via Chrome (55.0.2883.95) and Firefox (51.0.1) but both have the same issue.

It was working well a while back but I haven’t used it much since, thanks


Try Microsoft Edge browser - it worked much better for me and made the console actually useful. Chrome and Firefox seem to struggle.

As a test, open your digital ocean console in both Chrome and Edge at the same time side by side on your screen, enter a command in Chrome and Edge will update nearly immediately showing you the results. Chrome sits there forever before you see the results.

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

It’s apparently using PuTTY and if true it’s a shame!

Back again trying to modify the ssh key via the console so I can login and pasting a few characters at a time, checking there are not extra spaces and it hasn’t changed the case or suddenly started inserting in the middle of the text. Half an hour at this! Is there no other way?

All I use the console for is to add an ssh key so I can ssh in. It is soooooo slowwwwwwwwwwwww that even doing that is beyond it’s abilities. Pasting in about 30 chars at a time, waiting for it to work, checking it has reached the end of the line, pasting in the next 30 chars is the only way to do it. It’s excruciating and I’m taking a break to vent some of my frustration! Permission denied if I try and ssh in any other way. Oh and there is the entertaining way it gets stuck in toggling the capitalisation of text so that all the uppercase goes to lower case and visa versa. Only vi or nano, not on the command line. And it’s switched to dark blue on black (which I can’t read), how did that happen? I would so love a simple console that just worked!

This is a big issue for us - the console is close to useless. When the ssl deamon stops responding (a common issue on DO wms) debugging takes hours in stead of minutes. Sometimes I just delete and rebuild the droplet from a snapshot - way faster.

The DigitalOcean Web-based console is always a backup, emergency option for you to access your droplet, in those cases you mistakenly configured your firewall or SSH server.

Normally, you can simply open your Terminal in Launchpad, and type in ssh user@hostname(IP or domain) to access your server.

While demanding monitor boot status, I suppose properly configure logs is a better option.


Since the console (from within the DigitalOcean CP) is web based, I’ve noticed it can be a little slow at times, which is why I’ll normally use Terminal on my MBP – that and I prefer to have more control than what is provided from a web based solution.

When you can’t access Terminal, it’s a viable solution, though in most all other cases, Terminal is the best method to login to your server on a Mac.