DNS and sending emails

December 8, 2012 6.9k views
I set up google apps in association with my droplet, installed joomla on the droplet, set the site up to use the google apps to send email. I get the email from the google server however in the headers it has "Received-SPF: neutral (google.com: ###.###.###.### is neither permitted nor denied by best guess record for domain of me@mydomain.com)" (ip and email removed for privacy purposes) The IP listed in the header is not the ip of my site and domain. Can I set up and SPF record for the domain on Digital Ocean? If so - how would I do that? Thanks!
9 Answers
That sounds very likely like a configuration issue with google Apps Gmail.

Please make sure that you have enabled that domain for Gmail on Google Apps side and also on our side you can use our DNS management tool inside of the control panel to automatically add Google's Gmail records as your MX records for your domain.

After that once you have confirmed that you are able to send email from that server then you can check out if there is a Joomla configuration issue that may be causing the ultimate problem.
The google records are in the mx records - mail to the domain arrives in google apps perfectly - has been for a few weeks.

MX records:
Priority Hostname
Also the email sent from joomla is in the outbox on the google apps website so it appears that is all correct - is there a setting for this on google apps? Thanks for all the help.
There is a choice in google apps control panel: "Authenticate email - Set up email authentication (DKIM)" would this be benificial?
You should be able to send email through Google Apps mail by using your login credentials for a mailbox that you have setup.

But you can add them in and see if that helps.

I also think there should be a FAQ on google's side for this to see why they aren't being delivered since they are hitting the outbox.
I didn't say they weren't being delivered - they are delivered fine - the header has a message in it (read original post) and I would like to get rid of that message.
Add an SPF record and see if that resolves it, we support TXT records in the DNS management tool so you shouldn't have an issue adding one.
I added the SPF record - google apps still doesn't see it, says it could take 48 hours - I will check again on Wed.
FYI, you need to add quotes around the SPF record for DigitalOcean. That would be like the below (I hope the formatting works):

Name Action
@ "v=spf1 include:_spf.google.com ~all"
Have another answer? Share your knowledge.