Question

Droplet SSH Access denied - tried all since two hours

Hi,

i am desperate. I can’t access my droplet either with SSH keys or without. It works from the Droplet Console but it never worked with Putty. I followed many tutorials.

From what i have read this should work:

  • Reset root password
  • Connect with Putty to the Droplets IP address
  • Use root as user and the new emailed password

But still Access denied. What can i do wrong here? PermitRootLogin is set to yes

Anybody a solution? I need to backup some files urgently.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Hello there,

You can also check this tutorial where you can find steps on how to enable the password authentication on your droplet

https://www.digitalocean.com/community/questions/how-to-enable-password-authentication-on-server-digital-ocean

Regards

Since you can access your droplet via the Droplet Console. I assume you haven’t installed OpenSSH.

What output you get when running the following?

sudo ufw status

Hi @quinnhunt1981,

You get Access Denied as by default SSH Access with Password is denied. You need to enable PasswordAuthenitcation in your /etc/ssh/sshd_config and then restart the sshd service:

  1. service sshd restart

Now, in order to enter your Droplet, you’ll need to use the Recovery Console:

https://docs.digitalocean.com/products/droplets/how-to/recovery/recovery-console/