Question

How to enable password authentication on server(Digital Ocean)

I am trying to install server on runcloud through runcloud agent But he unable to make ssh into my server. It seems that the password authentication is not enabled on the server.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

i cannot reset the password .i was done all the changes but cant connect droplet

Hello @rumer878

In order to enable Password level authentication, you can follow these steps.

  1. Type sudo nano /etc/ssh/sshd_config
  2. Change PasswordAuthentication from “no” to “yes” and save the file
  3. Open a terminal on your computer and type ssh username@[hostname or IP address] or if on a Windows box use PuTTY for password login making sure authentication parameters aren’t pointing to a private key
  4. Login with a password
  5. Type sudo nano ~/.ssh/authorized_keys
  6. Paste public key text here and save the file
  7. Type sudo nano /etc/ssh/sshd_config
  8. Change PasswordAuthentication from “yes” to “no” and save the file
  9. Restart the ssh service: sudo systemctl restart sshd

Regards, Alex

Hi there,

In order to enable password authentication you need to edit the /etc/ssh/sshd_config file:

sudo nano /etc/ssh/sshd_config

Then find the PasswordAuthentication and set it to yes:

PasswordAuthentication yes

After that restart the SSH service:

sudo systemctl restart sshd

Hope that this helps! Regards, Bobby