Question

Enable Http/2 on DO Managed Load Balancer

Hi,

I’m setting up a droplet running a containerized nginx application, behind a DO Load Balancer. The SSL Termination is handled on the LB.

My goal is to have http/2 connection to the LB and then the communication is done over http with the server. However, my connection is still http/1.1. Am I missing something here? Does it needs something else? This is my first time doing this kind of setup, any guidelines are appreciated. I’m using nginx/1.18.0.

Many Thanks,

Gabriel


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Hi there @gabrielkodly,

HTTP/2 is supported on Managed Load Balancers. When setting up your forwarding rules, from the dropdown menu, you can select the protocol:

DigitalOcean Managed Loadbalancers HTTP2

Once you setup the forwarding rules, when hitting the Load balancer you should get the h2 header.

What is the output of the following command:

  1. curl -IL https://your_lb

I’ve just tested this with a fresh new Load Balancer and it worked as expected:

HTTP/2 200
server: nginx/1.14.0 (Ubuntu)
content-type: text/html; charset=UTF-8
cache-control: no-cache, private
...

Regards, Bobby