hello please i need help to fix this issue my website is showing me this remarque: Fatal error: Out of memory (allocated 2097152) (tried to allocate 40960 bytes) in /var/www/html/wp-content/plugins/td-composer/legacy/common/wpbooster/tdutil.php on line 2267 and i don’t have any plugins in my wordpress

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
2 answers

Hello, raminzr. You’re likely using the Newspaper or Newsmag theme, & these plugins accompany it.

Hi there @raminzr,

In addition to what @abletec mentioned, you could increase your PHP memory limit by adjusting the memory_limit value in your php.ini file. You can follow the steps in this tutorial on how to do that:

https://www.digitalocean.com/community/tutorials/how-to-change-your-php-settings-on-ubuntu-14-04

Let me know how it goes.
Regards,
Bobby

by Jon Schwenn
PHP is a server side scripting language used by many popular CMS and blog platforms like WordPress and Drupal. It is also part of the popular LAMP and LEMP stacks. Updating the PHP configuration settings is a common task when setting up a PHP-based website. This guide will show how to view the current PHP configuration settings of your web server and how to make updates to the PHP settings.
  • Hello thanks for your answer i tried this method but nothing happened i’ve created a swap space what do you think

    • Hi there @raminzr,

      I would recommend adding a PHP info file to your site to see if the memory limit change is actually taking effect:

      info.php
      <?php
      
      phpinfo();
      
      ?>
      

      Also after adding the info PHP file cross-check the location of the php.ini file and make sure that the changes that you are making are in that file.

      Note that after changing the values in your php.ini file you might have to restart Apache.

      If this still does not work I would suggest checking the contents of the /var/www/html/wp-content/plugins/td-composer/ folder and making sure that it does not contain any suspicious files.

      What you could try doing is to temporarily rename the plugins folder to something like plugins-backup and create an empty plugins folder.

      Let me know how it goes.
      Regards,
      Bobby

Submit an Answer