Question

How to connect to Managed Database Cluster using Workbench

I understand that it is not possible to use an SSH connection to a Managed Database server. That means I would need to use a TCP connection, right? I have tried entering the public host, port number, username doadmin, and password for doadmin (public) into the TCP parameters in Workbench. But I still get connection failed when I test the connection. Any ideas?

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Accepted Answer

Hi there @FrankJernigan,

What is the exact error that you get when you try to connect? Also, what is the Workbench version that you are using?

On another note, if you have enabled Trusted Sources for your Database Cluster, you would need to allow your IP address in order to be able to access the cluster.

Regards, Bobby

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.