Question

How to connect to Managed Database Cluster using Workbench

I understand that it is not possible to use an SSH connection to a Managed Database server. That means I would need to use a TCP connection, right? I have tried entering the public host, port number, username doadmin, and password for doadmin (public) into the TCP parameters in Workbench. But I still get connection failed when I test the connection. Any ideas?

Subscribe
Share

I am also having the same problem and it doesn’t gets resolved even after adding the IP in the trusted source list. The credentials are correct as I can connect to the managed DB using CLI from a DO droplet but not my local PC.

I have upgraded the Workbench to the latest release (8.0.28 build 1474738 CE 64 bits) but the issue still persists. Any other ideas to resolve this issue?


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Accepted Answer

Hi there @FrankJernigan,

What is the exact error that you get when you try to connect? Also, what is the Workbench version that you are using?

On another note, if you have enabled Trusted Sources for your Database Cluster, you would need to allow your IP address in order to be able to access the cluster.

Regards, Bobby