OpenLiteSpeed does not clear cache (deleted page showing)

I recently added an index.html at the server correct directory. I tested and it was ok. The problem is that I deleted the page and uploaded others BUT the old ‘index.html’ keeps being served. I tried to find some ‘flush cache’ at the Openlitespeed WebAdmin but there is no such option. What can be done?

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Accepted Answer

In fact I solved it myself. The problem was that “Virtual Host Root” had the wrong path at LiteSpeed Webadmin. And somehow it made the page get ‘cached’ I don’t know how.

After the insertion of the correct path the problem got solved.

OLS does not cache HTML at all , maybe it’s your browser cache ?

Try DigitalOcean for free

Click below to sign up and get $200 of credit to try our products over 60 days!

Sign up

Featured on Community

Get our biweekly newsletter

Sign up for Infrastructure as a Newsletter.

Hollie's Hub for Good

Working on improving health and education, reducing inequality, and spurring economic growth? We'd like to help.

Become a contributor

Get paid to write technical tutorials and select a tech-focused charity to receive a matching donation.

Welcome to the developer cloud

DigitalOcean makes it simple to launch in the cloud and scale up as you grow — whether you're running one virtual machine or ten thousand.

Learn more
DigitalOcean Cloud Control Panel