Question

Problems with PuPHPet, Vagrant & Digital Ocean API

Has anyone experienced any problems with Vagrant access to the API recently? In my case, with a PuPHPet setup?

I’ve suddenly stopped being able to connect & provision my droplet using Vagrant.

It’s been working OK for weeks, but just stopped today.

When I try to provision my box I get a “Token is required” error.

I did just install the vagrant rsync plugin, but after I got this error, I uninstalled it, but with no improvement.

Has anything changed with the API access recently has it, as I checked my account & can’t see any active API tokens.

The tokens currently configured are (scrambled, but shown for length indication)…

client_id: 2b6d90cd548a2c70e8ccfd4846e06603 api_key: b0f7dae57799d631a1cb200c974ef236

… however I can’t see a way of creating tokens in this format from the API Keys page any more?

I can only generate a token that is 64 characters long


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hi!

By default, the Apps & API page is showing the new version 2 of our API which only requires an OAuth token, not the Client ID and API keys. You can still reach the v1 API page that provides those keys here.

The vagrant-digitalocean plugin recently made a new release that changed to using v2 of our API. So if you are using that, you simply need the single token.

You can check out the full documentation for the new API here. It looks like PuPHPet already has an open bug to support the new API.