Resized droplet but fdisk still show 25gb

Recently got this error “ext4-fs (loop0) error loading journal” and server unable to boot up. Read here that it might be a disk full issue At this stage, fdisk show 25GB although I have been paying for 50GB (shown in the DO control panel). But I wanted a quick fix (DO support was not replying) and so tried resizing to 60GB. After which, server still did not boot. Console still show the same error. When I ran fdisk, it still shows 25GB. What can I do to resize the disk and get this back running? Please help


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Had the same problem. Followed this:

and then ran the following command: xfs_growfs /dev/vda1

I’ve tried the tutorial here on growpart But it doesn’t work as well. mkdir: cannot create directory, no space left on device.

What to do now?