Question

SSH root not asks for password

Hi The issue is that when i connect with root through ssh, it just connect without asking for password. Below is the what i modified in the config file. Anyone?

Authentication: PermitRootLogin yes PasswordAuthentication yes

ChallengeResponseAuthentication yes

UsePAM no

X11Forwarding yes PrintMotd no


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hello there,

If you provided an SSH key when creating your DigitalOcean droplet, password authentication may have been automatically disabled.

On another note, if you have your ssh-key added to your droplet, the password authentication can be skipped due to the presence of the ssh-key pair.

If you’re using an ssh-client in your terminal you can add the -vvv to the ssh command, e.g - ssh -vvv user@DropletIp to get a more verbose output of how the connection was established.

Regards