Hello, I’m trying to set up SSL on my server and I went for a test and it says that to make sure that the SSL port is open (default 443) is open on my server’s firewall. How would I go about doing that? I already obtained a certicate.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
2 answers

ufw allow 443

  • It tells me
    Skipping adding existing rule
    Skipping adding existing rule (v6)?

    Checked the SSL connection and it still says the port may be closed

    • How you check the SSL connection?

      openssl s_client -connect example.com:port

      [Like this?]

      Which web server you are using?

      sudo ufw allow http

      sudo ufw allow 80

      sudo ufw allow https

      sudo ufw allow proto tcp from any to any port 80,443

      • I checked the SSL Connection through Name Cheap. I purchased a certificate through them and added it to my server. My domain is hosted through Google domains.

        I tried those commands and I receive an error when I run

        openssl s_client -connect example.com:port

        • What’s the error says?

          And, If you like to install Let’s Encrypt which is free of cost please tell me.

          • The error is
            140546523346240:error:2008F002:BIO routines:BIOlookupex:system lib:../crypto/bio/baddr.c:726:Servname not supported for aisocktype
            connect:errno=0

            I tried to do Lets Encrypt, but that’s still not showing up when I check for the SSL

Which web server you are using? and is this a WordPress Website?

  • The web server is supposed to be Apache, but it has failed to start and I am receiving this error. Could this be the problem?

    pache2.service - The Apache HTTP Server
    Loaded: loaded (/lib/systemd/system/apache2.service; enabled; vendor preset: enabled)
    Active: failed (Result: exit-code) since Sat 2020-11-21 01:14:08 UTC; 3h 13min ago
    Docs: https://httpd.apache.org/docs/2.4/
    Process: 200244 ExecStart=/usr/sbin/apachectl start (code=exited, status=1/FAILURE)

    Nov 21 01:14:08 PlutoSocial apachectl[200262]: AH00558: apache2: Could not reliably determine the server’s fully qualified domain name, using 127.0.1.1. Set the ‘ServerName’ directive globally to suppres>
    Nov 21 01:14:08 PlutoSocial apachectl[200262]: (98)Address already in use: AH00072: makesock: could not bind to address [::]:80
    Nov 21 01:14:08 PlutoSocial apachectl[200262]: (98)Address already in use: AH00072: make
    sock: could not bind to address 0.0.0.0:80
    Nov 21 01:14:08 PlutoSocial apachectl[200262]: no listening sockets available, shutting down
    Nov 21 01:14:08 PlutoSocial apachectl[200262]: AH00015: Unable to open logs
    Nov 21 01:14:08 PlutoSocial apachectl[200244]: Action 'start’ failed.
    Nov 21 01:14:08 PlutoSocial apachectl[200244]: The Apache error log may have more information.
    Nov 21 01:14:08 PlutoSocial systemd[1]: apache2.service: Control process exited, code=exited, status=1/FAILURE
    Nov 21 01:14:08 PlutoSocial systemd[1]: apache2.service: Failed with result 'exit-code’.
    Nov 21 01:14:08 PlutoSocial systemd[1]: Failed to start The Apache HTTP Server.

Submit an Answer