Question

Trying to deploy Laravel 8 project on digitalocean app platform

this is my first time using digitalocean i don’t really know what i’m doing wrong or where to go from here, i need help. when i try to deploy, it seems to me that composer is unable to install packages. during the build process i get " WARNING: Your ‘composer.lock’ is out of date!" after which more errors come in and everything fails. I have done composer update multiple times on dev environment and push changes of my composer.json and composer.lock files to my gitlab repo but this error still shows.

this is the full message i got from the terminal

2021-12-21T10:24:21.350622932Z => Initializing build
2021-12-21T10:24:21.372135009Z => Retrieving source code to /workspace
2021-12-21T10:24:21.392783704Z => Selecting branch "main"
2021-12-21T10:24:24.763498288Z => Checking out commit "cde7a74310ac47a4c99128db8a334a6e7dcf76b8"
2021-12-21T10:24:26.735270266Z => Got source_dir: /
2021-12-21T10:24:26.751013729Z => Using workspace root /workspace
2021-12-21T10:24:26.781024894Z 
2021-12-21T10:24:26.781307356Z => Building app using buildpacks
2021-12-21T10:24:26.967950701Z => Injecting app environment variables:
2021-12-21T10:24:26.967988570Z      GOOGLE_CLIENT_ID GOOGLE_REDIRECT_URL NOVA_APP_NAME DB_CONNECTION DB_DATABASE APP_KEY APP_DEBUG DB_PASSWORD GOOGLE_CLIENT_SECRET DB_HOST DB_PORT GOOGLE_REFRESH_TOKEN APP_URL APP_NAME DB_USERNAME
2021-12-21T10:24:27.341255082Z => Running buildpack detection
2021-12-21T10:24:27.341308313Z 
2021-12-21T10:24:27.709006912Z 5 of 6 buildpacks participating
2021-12-21T10:24:27.709069833Z heroku/nodejs-engine       0.5.0
2021-12-21T10:24:27.709105708Z digitalocean/node          0.3.4
2021-12-21T10:24:27.709113667Z digitalocean/php-appdetect 0.0.3
2021-12-21T10:24:27.709120154Z heroku/php                 0.188.4
2021-12-21T10:24:27.709126660Z digitalocean/procfile      0.0.3
2021-12-21T10:24:27.789261132Z 
2021-12-21T10:24:27.789305706Z For documentation on the buildpacks used to build your app, please see:
2021-12-21T10:24:27.789372962Z    Node.js: https://do.co/apps-buildpack-node
2021-12-21T10:24:27.789389658Z    PHP: https://do.co/apps-buildpack-php
2021-12-21T10:24:28.126670405Z 
2021-12-21T10:24:28.127024677Z => Building app
2021-12-21T10:24:28.127151470Z 
2021-12-21T10:24:28.269144754Z ---> Node.js Buildpack
2021-12-21T10:24:28.279714510Z ---> Installing toolbox
2021-12-21T10:24:28.292072246Z ---> - jq
2021-12-21T10:24:28.557872608Z ---> - yj
2021-12-21T10:24:28.826742309Z ---> Getting Node version
2021-12-21T10:24:28.847912429Z ---> Resolving Node version
2021-12-21T10:24:31.256049878Z ---> Downloading and extracting Node v12.22.8
2021-12-21T10:24:44.991326902Z ---> Parsing package.json
2021-12-21T10:24:45.880778210Z ---> No file to start server
2021-12-21T10:24:45.880836056Z ---> either use 'docker run' to start container or add index.js or server.js
2021-12-21T10:24:45.912885746Z Project contains package-lock.json, using npm
2021-12-21T10:24:46.334489899Z Using npm v6.14.15. To configure a different version of npm, set the engines.npm property in package.json.
2021-12-21T10:24:46.334529173Z   See https://do.co/apps-buildpack-node for further instructions.
2021-12-21T10:24:46.334988628Z Installing node_modules using npm (from package-lock.json)
2021-12-21T10:24:46.683831152Z Running npm ci
2021-12-21T10:24:46.683865475Z 
2021-12-21T10:25:03.344374036Z added 810 packages in 15.727s
2021-12-21T10:25:03.357138243Z 
2021-12-21T10:25:09.117101087Z -----> Bootstrapping...
2021-12-21T10:25:20.693409013Z 
2021-12-21T10:25:20.729191882Z  !     WARNING: Your 'composer.lock' is out of date!
2021-12-21T10:25:20.729235382Z  !     
2021-12-21T10:25:20.731914956Z  !     The 'composer.lock' file in your project is not up to date with
2021-12-21T10:25:20.734956614Z  !     the main 'composer.json' file. This may result in installation
2021-12-21T10:25:20.736997973Z  !     of incorrect packages or package versions.
2021-12-21T10:25:20.737066440Z  !     
2021-12-21T10:25:20.739744612Z  !     The lock file is required in order to guarantee reliable and
2021-12-21T10:25:20.741987490Z  !     reproducible installation of dependencies across systems and
2021-12-21T10:25:20.743388702Z  !     deploys. It must always be kept in sync with 'composer.json'.
2021-12-21T10:25:20.743423665Z  !     
2021-12-21T10:25:20.745194616Z  !     Whenever you change 'composer.json', ensure that you perform
2021-12-21T10:25:20.746481615Z  !     the following steps locally on your computer:
2021-12-21T10:25:20.747479958Z  !     1) run 'composer update'
2021-12-21T10:25:20.749067665Z  !     2) add all changes using 'git add composer.json composer.lock'
2021-12-21T10:25:20.750038878Z  !     3) commit using 'git commit'
2021-12-21T10:25:20.750058319Z  !     
2021-12-21T10:25:20.751831170Z  !     Ensure that you updated the lock file correctly, and that you
2021-12-21T10:25:20.753344313Z  !     ran 'git add' on both files, before deploying again.
2021-12-21T10:25:20.753361431Z  !     
2021-12-21T10:25:20.755069583Z  !     Please remember to always keep your 'composer.lock' updated in
2021-12-21T10:25:20.756703429Z  !     lockstep with 'composer.json' to avoid common problems related
2021-12-21T10:25:20.758179083Z  !     to dependencies during collaboration and deployment.
2021-12-21T10:25:20.758201076Z  !     
2021-12-21T10:25:20.760160907Z  !     Please refer to the Composer documentation for further details:
2021-12-21T10:25:20.761209436Z  !     https://getcomposer.org/doc/
2021-12-21T10:25:20.762743038Z  !     https://getcomposer.org/doc/01-basic-usage.md
2021-12-21T10:25:20.768727319Z 
2021-12-21T10:25:20.862605986Z -----> Installing platform packages...
2021-12-21T10:25:31.875318483Z 
2021-12-21T10:25:31.900958856Z  !     ERROR: Failed to install system packages!
2021-12-21T10:25:31.901385780Z  !     
2021-12-21T10:25:31.904392729Z  !     Your platform requirements (for runtimes and extensions) could
2021-12-21T10:25:31.907164046Z  !     not be resolved to an installable set of dependencies, or a
2021-12-21T10:25:31.908841516Z  !     platform package repository was unreachable.
2021-12-21T10:25:31.908870768Z  !     
2021-12-21T10:25:31.911934719Z  !     This usually means that you (or packages you are using) depend
2021-12-21T10:25:31.914317847Z  !     on a combination of PHP versions and/or extensions that are
2021-12-21T10:25:31.915579096Z  !     currently not available on Heroku.
2021-12-21T10:25:31.915603724Z  !     
2021-12-21T10:25:31.918059761Z  !     The following is the full output from the installation attempt:
2021-12-21T10:25:31.918078597Z  !     
2021-12-21T10:25:31.920003801Z  !     > Loading repositories with available runtimes and extensions
2021-12-21T10:25:31.921078408Z  !     > Updating dependencies
2021-12-21T10:25:31.923449230Z  !     > Your requirements could not be resolved to an installable set of packages.
2021-12-21T10:25:31.924121689Z  !     > 
2021-12-21T10:25:31.924735264Z  !     >   Problem 1
2021-12-21T10:25:31.927890837Z  !     >     - Installation request for phpseclib/bcmath_compat 2.0.1 -> satisfiable by phpseclib/bcmath_compat[2.0.1].
2021-12-21T10:25:31.943688393Z  !     >     - phpseclib/phpseclib 3.0.12 requires php >=5.6.1 -> satisfiable by php[7.1.33, 7.2.26, 7.2.27, 7.2.28, 7.2.29, 7.2.30, 7.2.31, 7.2.32, 7.2.33, 7.2.34, 7.3.13, 7.3.14, 7.3.15, 7.3.16, 7.3.17, 7.3.18, 7.3.19, 7.3.20, 7.3.21, 7.3.22, 7.3.23, 7.3.24, 7.3.25, 7.3.26, 7.3.27, 7.3.28, 7.3.29, 7.3.30, 7.3.31, 7.3.32, 7.3.33, 7.4.10, 7.4.11, 7.4.12, 7.4.13, 7.4.14, 7.4.15, 7.4.16, 7.4.19, 7.4.2, 7.4.20, 7.4.21, 7.4.22, 7.4.23, 7.4.24, 7.4.25, 7.4.26, 7.4.27, 7.4.3, 7.4.4, 7.4.5, 7.4.6, 7.4.7, 7.4.8, 7.4.9, 8.0.0, 8.0.1, 8.0.10, 8.0.11, 8.0.12, 8.0.13, 8.0.14, 8.0.2, 8.0.3, 8.0.6, 8.0.7, 8.0.8, 8.0.9, 8.1.0, 8.1.1].
2021-12-21T10:25:31.946602006Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 7.3.13
2021-12-21T10:25:31.949163834Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 7.3.14
2021-12-21T10:25:31.951906846Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 7.3.15
2021-12-21T10:25:31.954270061Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 7.3.16
2021-12-21T10:25:31.956648158Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 7.3.17
2021-12-21T10:25:31.959111162Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 7.3.18
2021-12-21T10:25:31.961417231Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 7.3.19
2021-12-21T10:25:31.963490609Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 7.3.20
2021-12-21T10:25:31.966028072Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 7.3.21
2021-12-21T10:25:31.968535850Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 7.3.22
2021-12-21T10:25:31.971062036Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 7.3.23
2021-12-21T10:25:31.973782200Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 7.3.24
2021-12-21T10:25:31.976985950Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 7.3.25
2021-12-21T10:25:31.979793570Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 7.3.26
2021-12-21T10:25:31.982395402Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 7.3.27
2021-12-21T10:25:31.984979762Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 7.3.28
2021-12-21T10:25:31.987457050Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 7.3.29
2021-12-21T10:25:31.989773206Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 7.3.30
2021-12-21T10:25:31.991821217Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 7.3.31
2021-12-21T10:25:31.994324880Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 7.3.32
2021-12-21T10:25:31.996415560Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 7.3.33
2021-12-21T10:25:31.998649883Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 7.4.10
2021-12-21T10:25:32.001089623Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 7.4.11
2021-12-21T10:25:32.003099631Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 7.4.12
2021-12-21T10:25:32.005223640Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 7.4.13
2021-12-21T10:25:32.007420610Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 7.4.14
2021-12-21T10:25:32.009872416Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 7.4.15
2021-12-21T10:25:32.012200087Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 7.4.16
2021-12-21T10:25:32.014874564Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 7.4.19
2021-12-21T10:25:32.016723527Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 7.4.2
2021-12-21T10:25:32.018781446Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 7.4.20
2021-12-21T10:25:32.021151467Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 7.4.21
2021-12-21T10:25:32.023805574Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 7.4.22
2021-12-21T10:25:32.025748984Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 7.4.23
2021-12-21T10:25:32.028365460Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 7.4.24
2021-12-21T10:25:32.030356505Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 7.4.25
2021-12-21T10:25:32.033003118Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 7.4.26
2021-12-21T10:25:32.034975637Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 7.4.27
2021-12-21T10:25:32.037435168Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 7.4.3
2021-12-21T10:25:32.039357770Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 7.4.4
2021-12-21T10:25:32.041824147Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 7.4.5
2021-12-21T10:25:32.043786023Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 7.4.6
2021-12-21T10:25:32.046327404Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 7.4.7
2021-12-21T10:25:32.048455413Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 7.4.8
2021-12-21T10:25:32.050874488Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 7.4.9
2021-12-21T10:25:32.053466657Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 8.0.0
2021-12-21T10:25:32.055291018Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 8.0.1
2021-12-21T10:25:32.057739213Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 8.0.10
2021-12-21T10:25:32.059781094Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 8.0.11
2021-12-21T10:25:32.061962378Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 8.0.12
2021-12-21T10:25:32.064419117Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 8.0.13
2021-12-21T10:25:32.066605687Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 8.0.14
2021-12-21T10:25:32.068787315Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 8.0.2
2021-12-21T10:25:32.070873543Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 8.0.3
2021-12-21T10:25:32.072905031Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 8.0.6
2021-12-21T10:25:32.075341641Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 8.0.7
2021-12-21T10:25:32.077288300Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 8.0.8
2021-12-21T10:25:32.079725246Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 8.0.9
2021-12-21T10:25:32.081924489Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 8.1.0
2021-12-21T10:25:32.084375226Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 8.1.1
2021-12-21T10:25:32.086433628Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 7.1.33
2021-12-21T10:25:32.088953253Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 7.2.26
2021-12-21T10:25:32.091146526Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 7.2.27
2021-12-21T10:25:32.093048687Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 7.2.28
2021-12-21T10:25:32.095201260Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 7.2.29
2021-12-21T10:25:32.098010689Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 7.2.30
2021-12-21T10:25:32.100155586Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 7.2.31
2021-12-21T10:25:32.102551261Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 7.2.32
2021-12-21T10:25:32.104950181Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 7.2.33
2021-12-21T10:25:32.107032835Z  !     >     - don't install phpseclib/bcmath_compat 2.0.1|don't install php 7.2.34
2021-12-21T10:25:32.110101218Z  !     >     - Installation request for phpseclib/phpseclib 3.0.12 -> satisfiable by phpseclib/phpseclib[3.0.12].
2021-12-21T10:25:32.110851075Z  !     > 
2021-12-21T10:25:32.116236224Z  !     > Running update with --no-dev does not mean require-dev is ignored, it just means the packages will not be installed. If dev requirements are blocking the update you have to resolve those problems.
2021-12-21T10:25:32.116260144Z  !     
2021-12-21T10:25:32.118329789Z  !     A possible cause for this error is your 'composer.lock' file,
2021-12-21T10:25:32.120233891Z  !     which is currently out of date, as changes have been made to
2021-12-21T10:25:32.122121123Z  !     your 'composer.json' that are not yet reflected in the lock file.
2021-12-21T10:25:32.122337330Z  !     
2021-12-21T10:25:32.124767383Z  !     In order to guarantee reliable installation of system packages,
2021-12-21T10:25:32.126086840Z  !     Heroku uses information from 'composer.lock'.
2021-12-21T10:25:32.126635848Z  !     
2021-12-21T10:25:32.128728808Z  !     If you already attempted to fix the error above by updating the
2021-12-21T10:25:32.130372992Z  !     requirements in 'composer.json', remember to also update the
2021-12-21T10:25:32.132453063Z  !     lock file by running 'composer update', followed by a 'git add'
2021-12-21T10:25:32.134432888Z  !     and 'git commit' of the changes. The warning message further
2021-12-21T10:25:32.135898723Z  !     above contains step-by-step instructions.
2021-12-21T10:25:32.135916771Z  !     
2021-12-21T10:25:32.137829054Z  !     Please remember to always keep your 'composer.lock' updated in
2021-12-21T10:25:32.139622763Z  !     lockstep with 'composer.json' to avoid common problems related
2021-12-21T10:25:32.141449974Z  !     to dependencies during collaboration and deployment.
2021-12-21T10:25:32.141863028Z  !     
2021-12-21T10:25:32.144107403Z  !     For reference, the following runtimes are currently available:
2021-12-21T10:25:32.144126844Z  !     
2021-12-21T10:25:32.145640792Z  !     PHP:  8.1.1, 8.1.0, 8.0.14, 8.0.13, 8.0.12, 8.0.11, 8.0.10, 
2021-12-21T10:25:32.147352172Z  !     8.0.9, 8.0.8, 8.0.7, 8.0.6, 8.0.3, 8.0.2, 8.0.1, 8.0.0, 
2021-12-21T10:25:32.149182455Z  !     7.4.27, 7.4.26, 7.4.25, 7.4.24, 7.4.23, 7.4.22, 7.4.21, 
2021-12-21T10:25:32.151057727Z  !     7.4.20, 7.4.19, 7.4.16, 7.4.15, 7.4.14, 7.4.13, 7.4.12, 
2021-12-21T10:25:32.152926081Z  !     7.4.11, 7.4.10, 7.4.9, 7.4.8, 7.4.7, 7.4.6, 7.4.5, 7.4.4, 
2021-12-21T10:25:32.154481970Z  !     7.4.3, 7.4.2, 7.3.33, 7.3.32, 7.3.31, 7.3.30, 7.3.29, 
2021-12-21T10:25:32.156401162Z  !     7.3.28, 7.3.27, 7.3.26, 7.3.25, 7.3.24, 7.3.23, 7.3.22, 
2021-12-21T10:25:32.157741961Z  !     7.3.21, 7.3.20, 7.3.19, 7.3.18, 7.3.17, 7.3.16, 7.3.15, 
2021-12-21T10:25:32.160036976Z  !     7.3.14, 7.3.13, 7.2.34, 7.2.33, 7.2.32, 7.2.31, 7.2.30, 
2021-12-21T10:25:32.160663931Z  !     7.2.29, 7.2.28, 7.2.27, 7.2.26, 7.1.33
2021-12-21T10:25:32.160880748Z  !     HHVM: 
2021-12-21T10:25:32.160896324Z  !     
2021-12-21T10:25:32.162922264Z  !     Please verify that all requirements for runtime versions in
2021-12-21T10:25:32.164848320Z  !     'composer.lock' are compatible with the list above, and ensure
2021-12-21T10:25:32.167064872Z  !     all required extensions are available for the desired runtimes.
2021-12-21T10:25:32.167081487Z  !     
2021-12-21T10:25:32.168942360Z  !     When choosing a PHP runtimes and extensions, please also ensure
2021-12-21T10:25:32.170841325Z  !     they are available on your app's stack (heroku-18), and select
2021-12-21T10:25:32.172767966Z  !     a different stack if needed after consulting the article below.
2021-12-21T10:25:32.172790704Z  !     
2021-12-21T10:25:32.174909662Z  !     For a list of supported runtimes & extensions on Heroku, please
2021-12-21T10:25:32.177293251Z  !     refer to: https://devcenter.heroku.com/articles/php-support
2021-12-21T10:25:32.206954577Z  !     
2021-12-21T10:25:32.243035075Z  !     REMINDER: the following warnings were emitted during the build;
2021-12-21T10:25:32.280173954Z  !     check the details above, as they may be related to this error:
2021-12-21T10:25:32.322075553Z  !     - Your 'composer.lock' is out of date!
2021-12-21T10:25:32.327044561Z 
2021-12-21T10:25:32.334739903Z ERROR: failed to build: exit status 1
2021-12-21T10:25:37.951090160Z 
2021-12-21T10:25:37.951126466Z For documentation on the buildpacks used to build your app, please see:
2021-12-21T10:25:37.951143936Z    Node.js: https://do.co/apps-buildpack-node
2021-12-21T10:25:37.951300456Z    PHP: https://do.co/apps-buildpack-php
2021-12-21T10:25:37.954060193Z 
2021-12-21T10:25:37.954919734Z  ! Build failed (145)

please what should i do?


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hi there,

What is the PHP version that you are running locally on your machine? To me it looks like that you might have ran the composer install locally with an older PHP version which could be causing the problem.

If this is the case I could suggest trying to update your PHP version locally to a newer one and then give this another try.

Let me know how it goes. Best, Bobby