mleedix
By:
mleedix

vnc access denied ubuntu 12.04

December 20, 2013 5.1k views
Followed the instructions on DigitalOcean site to setup vnc on ubuntu 12.04. No errors noted during install. Yet when I use putty to try and connect the server consistently returns 'access denied'. I have checked and double checked my passwd. Also went back and 'vncpasswd' and changed it just in case. What am I missing?
9 Answers
What port are you trying to connect to?
Tutorial said 5901 so that is what I tried several times. Then found vino-preferences which said 5900 so I tried that.
Did you open port 5901 on your firewall?

Did you download the TightVNC client from http://www.tightvnc.com/download.php, on your local computer?
No. I ran the whole installation from this turotorial
https://www.digitalocean.com/community/articles/how-to-setup-vnc-for-ubuntu-12
Putty gives me the username/passwd prompt but after that is when I get access denied. If it helps I am on a local network still right now. My goal is to install this machine in another city and have access through vnc.
by Bulat Khamitov
VNC will allow you to connect to your server remotely, as well as be able to use your keyboard, mouse, and monitor to interface with that server. Get it setup on your Ubuntu 12 cloud server.
My apologies, I'm trying to access via putty on a windows 7 machine.
Pablo... I downloaded the viewer you mentioned. It does connect although it asks for permission from the ubuntu machine. Once I give permission from ubuntu it allows the connection.

For my intended purpose I can not have that security measure. No one will ever sit at this machine. It's going to be hidden in an office area. My vnc access will be the only connection. Would you happen to know where I can find the correct settings? cli is fine
"cli is fine"

If the CLI is fine, why install VNC at all; and not simply go w/OpenSSH on the remote computer?
Many Thanks to you Pablo. You put me on the right track.

In case this helps others - once connection was made by auth from the ubuntu machie a small icon appears up by your clock on the ubuntu machine. Click on that and and preferences, this gives you gui box very much like the one 'sudo vino-preferences' brings up in cli. Uncheck the box titled 'You must confirm each access to this machine' and your good to go.
Pablo, I'm running zm on the machine. Perhaps there is a better way, but my thinking was to be able to log into the machine directly and pull up the zm interface there in case of errors with zm. To be certain the cameras are connecting locally persay
Have another answer? Share your knowledge.