Question

Why is OpenDKIM not signing my mails using postfix?

Hi guys!

I am currently setting up OpenDKIM. I have followed the tutorial on this website but for some reason all the mails are not being signed.

Here my configurations: Postfix: https://pastebin.com/x3k4C1LT OpenDKIM: https://pastebin.com/BmWMtGDS OpenDKIM-default: https://pastebin.com/iEcgu5Qz

I tried to debug using swaks -t myname@gmail.com and using http://www.mail-tester.com But both verify that my mails are not being signed with DKIM.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hey friend!

Great question. Is the header missing entirely? I assume it is, but let me know if I’m reading incorrectly. Be that the case, I’m thinking it might be worth reviewing the Postfix logs when you send an email to see if there are any errors in the process. Perhaps that will reveal a bit more information. I found another tutorial that looks good too, but if you’re using ours there shouldn’t be anything wrong with it if used on the stated distro/version. This is the other good one I found though:

https://easyengine.io/tutorials/mail/dkim-postfix-ubuntu

Jarland