Question

Why won't my Droplet accept my new password via SSH?

I was having problems SSHing into my Droplet using SSH keys, so I reset my Droplet’s password. I couldn’t SSH in still, as it was telling me that my password was incorrect, despite it working on the online Console. So, in the console, I used passwd to change my password to something I’d know. Still doesn’t work in SSH (I’m on a Mac), so I have to log in via the online console every time.

Why isn’t my Droplet accepting my passwords when I SSH into it through Terminal?

I tried contacting Customer Support but after 3 days of this happening, and no response from anybody, I am questioning whether or not to even stay with DigitalOcean. This is ridiculous.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Accepted Answer

If you created your droplet using an ssh key it would not be configured to allow password authentication by default. To fix this you can edit your /etc/ssh/sshd_config file to ensure that PasswordAuthentication is set to yes. Then restart the ssh server with service ssh restart

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.