iinurmi
By:
iinurmi

Wordpress One click install DNS problem

February 4, 2015 2.4k views

Hi,
I am trying to set up my domain so that the actual domain name would show up in the browser, not the IP.

I have installed the Wordpress with the digital ocean one click install and followed these steps on setting up the host name.

Zone File looks like this (myaddress is not my real site):


$ORIGIN myaddress.com.
$TTL 1800
address.com. IN SOA ns1.digitalocean.com. hostmaster.address.com. 1423086262 10800 3600 604800 1800
myaddress.com. 1800 IN NS ns1.digitalocean.com.
myaddress.com. 1800 IN NS ns2.digitalocean.com.
myaddress.com. 1800 IN NS ns3.digitalocean.com.
myaddress.com. 1800 IN A 128.199.55.101

I have tried to change the wordpress URL several times, but when I change it to the domain name, it won't work anymore (cannot login etc. It seems like there is no path myaddress.com/wp-login.php).

I have the an A record with @ mark and correct IP adress.

Is there something wrong with my apache or wordpress configs?

4 comments
  • Hey @iinurmi I'm Also experiencing thhis problem. Have you found a way to fix it yet?

  • When you enter your domain name are you taken to your wordpress site (even if the address bar changes to the IP)? If not, then you will need to troubleshoot this first. It may take a bit for your DNS changes to propagate and before this you may have trouble reaching your droplet via it's domain name. Once the domain is resolving properly, updating your Wordpress settings should resolve the issue.

  • From another post:

    You might need to change (in WordPress) the site address:

    Settings>General site address and WordPress Address

    then you might want to use VelvetBlue URL updater plugin and use it to change

    http://188.226.134.124

    to:

    http://yourwebsite.com

    that will make sure any links and such are using the proper url.

    another good app is "search regex" it's more powerful than velvet.

    https://www.digitalocean.com/community/questions/hi-need-help-with-dns-wordpress-link-to-my-webshop-thank-you

  • if you exported your posts from another wordpress site and you still have the backup export, re-uploading them is easier than using those two apps mentioned in my other post (Settings>General site address and WordPress Address), you also need to go into setings permalink and change it to the style of link you had in your old blog.

    This works but you may still get broken links if some posts had one link style (according to date or post name) while others had another, so you will have to go to each and change them manually, having said that the bigger issue is fixed though.

1 Answer

This question was answered by @rami1:

From another post:

You might need to change (in WordPress) the site address:

Settings>General site address and WordPress Address

then you might want to use VelvetBlue URL updater plugin and use it to change

http://188.226.134.124

to:

http://yourwebsite.com

that will make sure any links and such are using the proper url.

another good app is "search regex" it's more powerful than velvet.

https://www.digitalocean.com/community/questions/hi-need-help-with-dns-wordpress-link-to-my-webshop-thank-you

View the original comment

Have another answer? Share your knowledge.