Question

Droplet has no interfaces after update?

I’m unable to connect to the droplet via SSH, the websites hosted on the droplet and the MySQL database on the droplet after updating. Around 2pm (-0400) I performed an update using apt update; apt upgrade -y followed by a droplet reboot. Since then I’ve been unable to access the droplet. The only access I have is through the web console.

What I’ve tried

  • Restarted the sshd service as suggested in another community thread

  • Checked if config Results:

lo             Link encap:Local Loopback
                   inet addr:127.0.0.1    Mask:255.0.0.0
                   inet6 addr: ::1/128  Scope:Host
                   UP LOOPBACK RUNNING   MTU:65536    Metric:1
                   RX packets:160  errors:0  dropped:0  overruns:0  frame:0
                   TX packets:160  errors:0  dropped:0  overruns:0  carrier:0
                   collisions:0  txqueue1en:1
                   RX bytes:11840 (11.8 KB)      TX bytes:11840 (11.8 KB)
  • Tried manually restarting the networking service with service networking restart Returns: Job for networking.service failed because the control process exited with error code. See "systemctl status networking.service" and "journalctl -xe" for details.
  • Checked both of those, same result. “Cannot find device eth0, Failed to bring up eth0”
  • Tried turning it off and turning it back on
  • Tried other suggestions from StackOverflow, Ubuntu Forums and the DO community. Everything is either out of date, not working or doesn’t help because it’s for a different OS.

I’ve submitted a ticket a few hours ago, but I have yet to receive a reply and I’ve been unable to access any of the resources on the droplet for almost 9 hours now. If anyone has had this problem and resolved it, I’d love to know how you did it.

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Accepted Answer

@markwatneyy

Okay, did you confirm that you were on a previous kernel after reboot?

It’s quite difficult to know what went wrong. I would probably recommend that you start the Recovery Image (you have to request that through support) and transfer data to a new droplet. I’m guessing you don’t have backups running?

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

dot in 50-cloud-init.cfg makes ifup ignoring that file. after rename - all works. I am looking for resolution of work-a-round so far. One w-a-r is a symlink on .cfg file

Hello Friend! I have the same problem. How did you solve it?

@hansen That’s what I ended up doing, thanks for the help