Question

Can't connect to my droplet via SSH

  • Posted September 5, 2014

Hello guys! I cannot connect to my Droplet via Putty & iPhone App - Server Auditor. I’m use CentOS 6.5, zPanel. I tried to “power circle” from web interface. But my droplet steel down. Anybody, help me please!

Subscribe
Share

If you able to connect to the droplet via the web console in the DigitalOcean Control Panel, then restart the SSHD service for once.

Root > service sshd restart

You can use this online tool to confirm whether your SSH is active http://www.infobyip.com/sshservertest.php

Hope it helps :)

firstly, thank you valley_webuzo for your link. It is useful :) All: I think your firewall is reason that you can not connect ssh to server.

Same here with Ubuntu OS. I can access through web console but can not access through ssh. I tried above all suggested steps but none of them worked. Kindly help me.

same here. i can connect to nyc3 and sfo1. but i tried to set up in sfo2 and it just sits there with no response at all. connection timed out.

Help! Suddenly not able to connect to droplet via SSH. This after editing ssh_config to add a Host * ServerAliveInterval 120 to keep node and java running. Now I get these: macMini:~ x049709$ ssh -vvv x049709@x.243.212.x OpenSSH_6.9p1, LibreSSL 2.1.8 debug1: Reading configuration data /etc/ssh/ssh_config debug1: /etc/ssh/ssh_config line 20: Applying options for * debug1: /etc/ssh/ssh_config line 102: Applying options for * debug2: ssh_connect: needpriv 0 debug1: Connecting to x.243.212.x [x.243.212.x] port 22. debug1: connect to address x.243.212.x port 22: Connection refused ssh: connect to host 162.243.212.x port 22: Connection refused* I tried dpkg-reconfigure openssh-server - didn’t work. DB port 3306 still works

same here

Hi, I have go to http://www.infobyip.com/sshservertest.php and test my droplet. But it say: Cannot connect to 162.243.211.232:22 Please help me connect to my droplet. Thanks!

Same thing happened to me. I can only access the “web console” in the digitalocean control panel.


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

I had this problem for a while, in the end I just had to specify my IP address to the firewall. I did this in the DO Droplet Console.

sudo ufw allow from 15.15.15.51   #add your own IP here (Home or work IP not droplet IP)

More information here: https://www.digitalocean.com/community/tutorials/how-to-set-up-a-firewall-with-ufw-on-ubuntu-16-04

You can allow ssh from digital ocean droplet console all you need is to run sudo ufw allow ssh command it will enable your ssh again

Hey there I think you need to check whether you are using non-standard ports to connect i.e the typical is sftp://username@xxx.xxx.xxx.xx:22 but in fact if you set non standard ports it could be sftp://username@xxx.xxx.xxx.xx:nn (where n is any number) . Hope that helps someone.

Try connecting with ssh root@…