Error Downloading metadata for repository 'digitalocean-agent'

I have a CentOS 8 based droplet and from today, dnf/yum update/install commands are not working. I am getting the following error now:

DigitalOcean Agent 0.0 B/s | 0 B 01:20
Errors during downloading metadata for repository ‘digitalocean-agent’:

I have tried running on 2 different droplets and got the same error.

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Accepted Answer

Found the problem. Had restricted all outbound traffic via the firewall.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.