Question

FileZilla can't connect to SSH, keeps asking for password SSH password

I’ve tried not using a passphrase through putty, and it asked for a password, and I hadn’t entered one anywhere. So I tried again, using a passphrase and pageant just as the various instructions I’ve read have said.

But even after all that Filzilla will attempt to connect to the server, and then ask for a password. I’ve tried filling in my passphrase. I’ve tried leaving it blank.

Any help would be appreciated. I’ve been at this hours and I’m losing my mind.

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Accepted Answer

Hi @Lake

If you created the droplet without SSH key, then you will receive the SSH password via email. And you would connect with the user root and the password you have received, but you will be asked to change the password at first login. So it’s recommended to connect via PuTTY first time to set a custom password and then you can connect via FileZilla.

If you created the droplet with SSH key, then you would have to use that private SSH key to login to your droplet. There will be no password prompts (unless you created the SSH key with a passphrase). You can follow this tutorial to use a SSH key with FileZilla: https://www.digitalocean.com/community/tutorials/how-to-use-filezilla-to-transfer-and-manage-files-securely-on-your-vps