HHVM unable to run any scripts

  • Posted September 28, 2014

I recently installed HHVM on a local machine(Ubuntu 14.04) and it worked great, however when I installed it on a droplet running same the OS, it gives me a (unknown exception was thrown) error when I try to run any scripts, even a simple Hello World.How should I proceed to fix that?

Thank you.


I just destroyed the droplet, created a new one(ubuntu 14.04), created a user with root permission, logged in, installed hhvm following:, made a hello world in hacklang and got the same error.

I installed it following these instructions:, also executed the script(I dont know if that’s relevant since it configures the server(using nginx), and I’m not even able to execute hhvm directly from bash). I’m just getting this error:

hhvm test.php (unknown exception was thrown)

same thing on the hhvm error log.

How did you install HHVM on the droplet? Can you post the full error?

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Sorry to see that your question hasn’t received an answer yet. Unfortunately, after this much time, it is unlikely that an answer for this specific question will be provided. For people still landing here via search, check out this tutorial on installing and configuring HHVM:

This comment has been deleted