My root domain is not forwarding to www

I’m sure this question has been asked a thousand times, but I’ve followed all of the instructions I could find and I can’t get my root domain to redirect to www.

My server was pre-installed with WordPress, but then I decided to configure it to accommodate multiple sites/domains on one server. I assume, my domain/site previously redirected to www, but I can’t say for sure.

I would appreciate some help.

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Ok, it seems the issue was an .htaccess file left in the root directory my www folder (after I moved the site occupying that directory into a sub-directory). So it seems suggestions to investigate the .htacess file was a step in the right direction. Thanks for your help everyone.

You can also go directly to WordPress settings and into menu Settings -> General you can find two options “WordPress Address (URL)” and “Site Address (URL)”. You simply have to edit both URLs with or without www, like you prefer.