Network not working after taking droplet snapshot

Hello DigitalOcean,

I have an issue with my droplet. It is currently using Ubuntu 18.10 and I wanted to update to Ubuntu 18.04 LTS, so I decided to shut it down and take a snapshot. When I took the snapshot, I booted the droplet, but unfortunately after restarting. I can’t log in with SSH Key. Apache is running but I can’t access the IP via the browser too (it results in connection timed out). It shows on the droplet status that it is running but the web page is not working. I decided to restore the snapshot to the droplet but it won’t work.

Please help me find out what is going wrong, my website is off since soon 48hours, I contacted DO still no response.

Thanks, Franz

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Accepted Answer

After 3 days of struggle, I finally solved it. It is similar to this issue from @lukasea17033bb7e7ecf80fc21

Thanks, Franz

Site Moderator
Site Moderator badge
July 16, 2020

Hi @rigledev,

You can use your droplet’s console. The console can be found in your Control Panel --> Droplet’s settings —> Access --> Launch Console.

From there you can try typing in

service network restart

To see if it would start if it would give you an error.

Once you have the error, you should be able to resolve it with a quick search. If the error is not something you have access to fix, it would be best to see the response of DigitalOcean’s support. Having said that, please do try to restart your network from your console.

Regards, KFSys

Same issue here on 2x ubuntu Droplets (VMs) - one ubun20, the other ubuntu22.

Apache seems to work after restoring from a snapshot, but SSH does not, and the DO console just time-out on “Connecting to droplet”. (eventually showing SSH connection Lost)

I miss the old DO console, while it didnt support copy/paste, it always worked (which is what a console is supposed to be). :(

(edit- i should add one of these was a Wordpress One-click-app droplet, which runs on ubntu22)

Try DigitalOcean for free

Click below to sign up and get $200 of credit to try our products over 60 days!

Sign up

Featured on Community

Get our biweekly newsletter

Sign up for Infrastructure as a Newsletter.

Hollie's Hub for Good

Working on improving health and education, reducing inequality, and spurring economic growth? We'd like to help.

Become a contributor

Get paid to write technical tutorials and select a tech-focused charity to receive a matching donation.

Welcome to the developer cloud

DigitalOcean makes it simple to launch in the cloud and scale up as you grow — whether you're running one virtual machine or ten thousand.

Learn more
DigitalOcean Cloud Control Panel