New droplets always give timeout

Hello everyone as the title says, i can not connect to any droplet, i tried directly with ssh root@ip and i tried with putty and i tried with winscp i tried creating droplets with password or with ssh keys, but no difference.

none of the above ways, managed to connect me to my droplets, i always end up getting timeout errors mind you, these are a newly created droplets.

please note, the Console button in my droplet, does open a console window properly, but when i want t connect manually, it just times out and i tried connecting from multiple machines, too but no difference.

Submit an answer
Answer a question...

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

@Bobby lliev @KFSys

Thank you for the response guys, it really was an IPS i don’t know why, i don’t know how, but they appearently, messed something up with my connection, and i can no longer connection to anything through some ports? (Winscp/putty/ssh) on anywhere, i even attempted with linode, and other servers at digital ocean (tried newyork san fransisco and amesterdam), but, same error.

i reset my router to factory settings, and same result and lastly, the only thing that worked, was switching to my mobile internet, and connecting my laptop to it, and that worked.

so sadly, i don’t know what they did to my adsl line, but they are blocking it right now, really annoying, but eh.

Thanks for the help guys

Site Moderator
Site Moderator badge
March 29, 2022

Hi @MotasemZakarneh,

This sounds like a local issue, either with your router, or with your Firewall, or with your ISP.

Try using a different network, maybe the one from your phone and see if you still have the same issues or not?

It’s worth a try contacting your IPS as well, the issue may be coming from them.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Bobby Iliev
Site Moderator
Site Moderator badge
March 28, 2022


What I could suggest is running an MTR or a traceroute from your local computer to the Droplet’s IP address.

It sounds like that your ISP might be blocking the connection. If this is the case, you could try using a VPN and also contacting your ISP in the meantime.

Feel free to share the MTR here after removing any sensitive information.