Getting cipm can only install packages with an existing package-lock.json error on deploy because there is no package-lock.json (or yarn.lock, for that matter) on my repository. I’m using pnpm.

Tried changing the build command to pnpm build, hoping that pnpm would be installed and used for installation, but got the same error.

No way to use pnpm? Do I need to install my deps using npm and push my lockfile? Because if that’s so, that’s a deal breaker for me.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
Submit an Answer
1 answer

Hey there!

App Platform doesn’t support pnpm out of the box unfortunately. However you could use this in a Dockerfile build instead. That should allow for installation of any necessary software.

The underlying build-packs(Heroku) don’t yet support pnpm as far as I can tell. Should it be added in the future, I don’t see any reason it wouldn’t be added to ours as well.