Question

App platform build with pnpm command. Possible?

Getting cipm can only install packages with an existing package-lock.json error on deploy because there is no package-lock.json (or yarn.lock, for that matter) on my repository. I’m using pnpm.

Tried changing the build command to pnpm build, hoping that pnpm would be installed and used for installation, but got the same error.

No way to use pnpm? Do I need to install my deps using npm and push my lockfile? Because if that’s so, that’s a deal breaker for me.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hey there!

App Platform doesn’t support pnpm out of the box unfortunately. However you could use this in a Dockerfile build instead. That should allow for installation of any necessary software.

The underlying build-packs(Heroku) don’t yet support pnpm as far as I can tell. Should it be added in the future, I don’t see any reason it wouldn’t be added to ours as well.