App Platform Deploy Error: Health Checks, DeployContainerHealthChecksFailed

After deploying my NestJS api service, it started properly as seen on this screenshot of the deployment logs. But everytime, the health checks fails, which inhibits me from deploying.

I tried, according to the documentation, with a TCP health check, initally on my set port which was 3333, followed by the default port which is 8080, but both without success. I then went on and implemented a service health check route, under /api/health, but once again it still fails. You can take a look at my open-source config/project here.

It doesn’t seem to be giving any other information… Please let me know how I can fix it, or how I can turn off this check.

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Steven Normore
DigitalOcean Employee
DigitalOcean Employee badge
October 18, 2020
Accepted Answer

@gabrielbottari 👋

Thanks for sharing the open source project and config. I forked the project and deployed it via the .do/app.yaml. I hit the same failing health checks error that you described. The problem is a subtle one that we need to get better at surfacing in the platform. Notice at the bottom of the deploy logs that we see this from nestjs:

Server listening at

It’s listening on — so only connections targeting will be consumed. The resolution for this is to update the code to listen on instead (4e008e1). After making that update, it deploys successfully:

In case you have an app on NUXT. Configure the Nuxt.js server to see your site on deployment.

#in nuxt.config.js

export default {
    server: {
     port: 8080, // default: 3000
     host: '' // default: localhost

#in package.json

"config": {
    "nuxt": {
      "host": "",
      "port": "8080"

source from:

I had this exact same isssue with a node fastify-server. Adjusting the host name in the fastify config worked perfectly. I am trying to move over from Heroku, and this answer took WAY to long to find.

Try DigitalOcean for free

Click below to sign up and get $200 of credit to try our products over 60 days!

Sign up

Featured on Community

Get our biweekly newsletter

Sign up for Infrastructure as a Newsletter.

Hollie's Hub for Good

Working on improving health and education, reducing inequality, and spurring economic growth? We'd like to help.

Become a contributor

Get paid to write technical tutorials and select a tech-focused charity to receive a matching donation.

Welcome to the developer cloud

DigitalOcean makes it simple to launch in the cloud and scale up as you grow — whether you're running one virtual machine or ten thousand.

Learn more
DigitalOcean Cloud Control Panel