The domain settings seem somewhat limited right now, and I guess it will evolve. But is there any way to get wildcard subdomains working at this point?

1 comment
  • I sit now with same issue .. have a project that uses subdomain request to route to a ‘tenant’ in postgres shared database but specific schema … is this possible in DO Droplet/Nginx?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
Submit an Answer
2 answers

Hi engborg,

At the moment we don’t support wildcard subdomains. I’ve taken note of this as a feature request.

Best,
Moises

+1 @meskinazi Any updates since October 6?

  • Yes, we now support custom wildcard domain.

    You must add the domain before you can use the wildcard. For example, if you want to add *.example.com, example.com must be added to your app first.

    • How do I do this? I have tried adding an A Record with the hostname of * but this hasn’t worked. Am I missing something here?

    • With this configuration also not working
      A => example.com
      A => *.example.com
      CNAME => * ( Not Allowed )

      How’s your configuration @meskinazi ?

      • Wildcard CNAMEs are supported. When creating the record ensure the “Hostname” (other providers may call this “Record Name”) field is set to “*”. The “Is an Alias Of” (other providers may call this “Target”, or “Value”) should be set to your App’s full “ondigitalocean.app” name.

        The example posted above looks like the fields may be backwards.