Question

Unauthorized: "Unable to authenticate you" When attempting to link Github for app deployment

Hi all, I’m trying to deploy a Django through DO app platform, however when I attempt to allow access to the repo I get the message in the title. In my GitHub settings/applications it shows DO as installed with access, but on DO I still get the message “We don’t have access to your GitHub repositories”.

I’ve tried what was suggested here: https://www.digitalocean.com/community/questions/we-don-t-have-access-to-your-github-repositories But relogging on both DO and GitHub didn’t have any effect. Any help would be appreciated.

Thanks, Connor


Submit an answer


This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Accepted Answer

Switched to an incognito tab, and it seems to have worked fine. Must be an issue on my end with add-ons or some such. Can’t believe I didn’t think of it sooner.

Try DigitalOcean for free

Click below to sign up and get $200 of credit to try our products over 60 days!

Sign up

Get our biweekly newsletter

Sign up for Infrastructure as a Newsletter.

Hollie's Hub for Good

Working on improving health and education, reducing inequality, and spurring economic growth? We'd like to help.

Become a contributor

Get paid to write technical tutorials and select a tech-focused charity to receive a matching donation.

Welcome to the developer cloud

DigitalOcean makes it simple to launch in the cloud and scale up as you grow — whether you're running one virtual machine or ten thousand.

Learn more
DigitalOcean Cloud Control Panel