Question

WordPress 1-Click Install Not Working

Posted November 17, 2021 67 views
WordPressUbuntu 20.04

Hey all,

I’m trying to create a new droplet using the DO 1-click WordPress/Ubuntu 20.04 droplet from the Marketplace. I have tried around 7 times, closely following the instruction and got the same end results:

  1. Configured and created the new droplet
  2. Logged in as root user via ssh (I’ve tried from both the online DO console and Putty) and completed the interactive script successfully
  3. I’m then instructed to visit the site in a browser to complete the WordPress installation, but when I do this, I’m greeted with a site that has no styling and I’m unable to log into WordPress using the WordPress user I setup while running the install script via ssh (receive a 405 error)

Here is an example of what I’m seeing

Has anyone else experienced this? I’m unsure of how to proceed with this.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
Submit an Answer
1 answer

Hi @jplafata,

I just created a new WordPress droplet and followed it through all the way, I can confirm everything worked properly for me and my website got all the CSS and everything as it’s supposed to.

Can you please confirm what options are you selecting? Additionally, I saw you are visiting the HTTP part of your page. Can I suggest you to install a Let’s Encrypt certificate and redirect it to https.

Additionally, not sure if you have provided a domain but I would suggest you to do that as well.

  • Ah yes, it was that I provided a domain during the automated 1-click script, but the droplet did not have that domain configured yet. I just started with a fresh droplet, configured the domain, then ran the automated script in the new droplet and everything looks great now. Thanks for your suggestion~

    • Hi @jplafata,

      Glad to hear it’s working alright. Yes, if you don’t have a domain pointed to your droplet but add it and then access the website via the IP address it will load that way.