Question

Can't Install Or Update Wordpress Plugins

I’ve checked around the web quite a bit for a solution to this, but despite a lot of people having the issue, as well as there being answers, nothing seems to work for me. For whatever reason, I can’t install, or update plugins. When I attempt to, I’m met with an ftp login on the Wordpress page, which from my understanding means that my persmission or owner is wrong.

I’ve tried:

-Setting my settings on wp-content to 777 (temporarily of course) -sudo chown -R myuser:www-data /var/www/anightinburlington.com/public_html/*

Neither of those worked, and I’m not sure what’s wrong. I’ll be here all day, speakers loud, email notifications ready - if anyone could help, I’d be more than thankful!

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hi there,

Hopefully this isn’t still and issue for you, but I recently came across the same problem…

In my case my permissions where correct.

The fix for me is to add a line into wp-config.php, adding the following fixed it all. define(‘FS_METHOD’, ‘direct’);

Hope that helps someone in the future.

This comment has been deleted

I had the same problem, I was selecting FTPS (I was pretty sure it was correct), so I tried SSH2 without authentication keys and it worked.