Question

How to enable ssl in my droplet

I added an SSL certificate to my droplet domain, but when I try to open a URL it responds to http://raisze.backend.space:8000/admin and not to https://raisze.backend.space:8000/admin. I am a beginner please help.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hello there,

I’ll also recommend using Nginx as a reverse proxy for your Django application, on an additional note by using DigitalOcean’s App Platform solution all of that is handled for you.

You can check this question which was previously asked in our community

https://www.digitalocean.com/community/questions/how-can-i-add-ssl-certificate-to-my-django-website

Regards

Hi @massivegreenbluescubadiver,

First, I’ll recommend adding Nginx as a reverse proxy and configuring the SSL in there. Here is an article on how to achieve that:

https://www.digitalocean.com/community/tutorials/how-to-set-up-django-with-postgres-nginx-and-gunicorn-on-ubuntu-16-04

From the article check only the Nginx reverse proxy stuff. Once you have nginx and configured to work as a reverse proxy, I’ll recommend to renew your Let’s Encrypt with Certbot and have it apply the HTTPS configuration to Nginx automatically. Running

  1. certbot renew

and then following the options should do the trick.