Question

MySQL Daemon failed to start.

Recently I started working on a very basic Drupal website for a friend, by doing that it sadly seems that it has overloaded mysql. Can it really be that 1 Drupal install on a 512mb droplet eats up all the swap?

Anyway, I’m running CentOS with NginX, php-fpm, mysqld.

I’ve checked the mysqld.log and every time I try “service mysqld restart” this is what shows up in the log:


131128 22:05:57 mysqld_safe Starting mysqld daemon with databases from /var/lib/mysql 131128 22:05:57 [Note] Plugin ‘FEDERATED’ is disabled. 131128 22:05:57 InnoDB: The InnoDB memory heap is disabled 131128 22:05:57 InnoDB: Mutexes and rw_locks use GCC atomic builtins 131128 22:05:57 InnoDB: Compressed tables use zlib 1.2.3 131128 22:05:57 InnoDB: Using Linux native AIO 131128 22:05:57 InnoDB: Initializing buffer pool, size = 128.0M InnoDB: mmap(137363456 bytes) failed; errno 12 131128 22:05:57 InnoDB: Completed initialization of buffer pool 131128 22:05:57 InnoDB: Fatal error: cannot allocate memory for the buffer pool 131128 22:05:57 [ERROR] Plugin ‘InnoDB’ init function returned error. 131128 22:05:57 [ERROR] Plugin ‘InnoDB’ registration as a STORAGE ENGINE failed. 131128 22:05:57 [ERROR] Unknown/unsupported storage engine: InnoDB 131128 22:05:57 [ERROR] Aborting

131128 22:05:57 [Note] /usr/libexec/mysqld: Shutdown complete

131128 22:05:57 mysqld_safe mysqld from pid file /var/run/mysqld/mysqld.pid ended

To my knowledge, it seems that it can’t load into swap or something similar to that, but I could be wrong.

Anyone know how I can solve this?


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Never mind, updated to mysql 5.5 and now the performance_schema=off works, thanks for the help :)

I tried setting performance_schema=off in my.cnf yet that only results in mysql not wanting to start at all, with this error in the log: <br> <br>131227 0:24:06 [ERROR] /usr/libexec/mysqld: unknown variable ‘performance_schema=off’ <br>131227 0:24:06 [ERROR] Aborting <br> <br>Which just confuses me, after checking what version of Mysql I’m running, it’s 5.1.71 (which is the version that is installed via the guide for CentOS LAMP server) and yum doesn’t return a newer version, should I upgrade to a newer version to solve my issue or could it be elsewhere?

Add performance_schema = off to MySQL confiugration file solved the issue!