Question

SYSTEM_VARIABLES_ADMIN permission

I wnt to connect my MYSQL Database to airbyte, but it does not let me. Airbyte answers:

Could not connect with provided configuration. The DB user provided to airbyte was unable to switch on the local_infile attribute on the MySQL server. As an admin user, you will need to run “SET GLOBAL local_infile = true” before syncing data with Airbyte.

I Used the doadmin to try logging in and I am not able to SET GLOBAL local_infile = true


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Hi @schieferlelouis,

By default, we have disabled local_infile ( or “LOAD DATA LOCAL”) on managed database cluster for security reasons. Please refer to the link below for more information : https://dev.mysql.com/doc/refman/8.0/en/load-data-local-security.html

As a workaround, I’d suggest reviewing the below links to see if it would be suitable for your use case. These tools can be used to convert and transform big files of CSV to MySQL.

https://numidian.io/convert/csv/to/mysql https://sqlizer.io/#/

I hope this helps.

Regards, Anadi