Question

Using Parcel, logs show its trying to run on localhost

I was trying to deploy a simple Node.js app which uses parcel. When deploying I get a successful deployment but the page does not display and I get these errors:

[lit-chat] [2022-03-23 22:08:23] yarn run v1.22.18 [lit-chat] [2022-03-23 22:08:23] $ parcel index.html [lit-chat] [2022-03-23 22:08:50] Server running at http://localhost:8080 [lit-chat] [2022-03-23 22:08:50] Building…

How do I tell the deployment to bind to the given public url? I have tried specifying the --public-url in package.json as well but there was no change.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hello,

I believe that you should be able to specify the host that your Parcel app binds on using the --host argument.

In your case you could use --host 0.0.0.0 so that the Parcel app would be accessible from the outside world.

Alternatively, you could leave the app on localhost and use Nginx as a reverse proxy. For more information on how to do that you can take a look at step 5 here:

https://www.digitalocean.com/community/tutorials/how-to-set-up-a-node-js-application-for-production-on-ubuntu-16-04#step-5-setting-up-nginx-as-a-reverse-proxy-server

Hope that this helps.

Best,

Bobby