Question

Cannot access the host to connect a database via SSH tunneling while getting "Permission denied (publickey)."

Posted April 12, 2020 2.1k views
Databases

After running docker and creating an own PostgreSql database in a droplet, I can access the host via “ssh root@xx.xx.xx.xx” but I cant connect to the database via SSH tunneling. Here is the command and its response:

root@ubuntu-database:~# ssh -L 5432:localhost:5432 -N -f -l root XX.XX.XX.XX Permission denied (publickey).

I'be assigned the droplet with SSH security rather than using one-time email. Currently, I really have no idea of what is the cause of the problem -whether it’s from the droplet configuration, docker, PostgreSql setting, or SSH usage. I’m an amateur and quite new for this matter. Please kindly help.

Thank you very much.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
Submit an Answer
2 answers

Hi @valorvignette,

Using SSH Tunneling won’t get your SSH key automatically like using plain SSH. You’ll need to pass it down the command you use.

ssh -N -L 5432:127.0.0.1:5432-i /path/to/ssh/key root@XXX.XXX.XXX.XXX

Please don’t forget to chage both the path and the XXX. with your actual IP address.

Regads,
KDSys

Hello there,

You can check our article on How to Upload an SSH Public Key to an Existing Droplet

https://www.digitalocean.com/docs/droplets/how-to/add-ssh-keys/to-existing-droplet/

You can access the droplet from the DigitalOcean console and then temporary enable the PasswordAuthentication on your droplet and access the droplet with a password to upload the ssh-key.

If you haven’t created new pair of keys you’ll need to do that first.

You can enable PasswordAuthentication for your Droplet by modifying your /etc/ssh/sshd_config file. Once set to Yes restart the SSH service and connect via an SSH client for a more stable connection. You can then modify your ~/.ssh/authorized_keys file to add the appropriate public key.

This change can be made from the DigitalOcean’s console. If you’re having issues accessing the console you can then reach to our amazing support team that can help you further with this.

To enable the PasswordAuthentication follow these steps:

  1. Login to the console on the DigitalOcean website.
  2. Type sudo nano /etc/ssh/sshd_config
  3. Change PasswordAuthentication from “no” to “yes” and save the file
  4. Open a terminal on your computer and type ssh username@[hostname or IP address] or if on a Windows box use PuTTY for password login making sure authentication parameters aren’t pointing to a private key
  5. Login with a password
  6. Type sudo nano ~/.ssh/authorized_keys
  7. Paste public key text here and save the file
  8. Type sudo nano /etc/ssh/sshd_config
  9. Change PasswordAuthentication from “yes” to “no” and save the file
  10. Log out and attempt to log back in (if using PuTTY make sure you set up auth parameters to point to your private key)

You can then upload the key using this command:

ssh-copy-id -i ~/.ssh/mykey user@droplet

Hope that this helps!
Regards,
Alex